Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-21187

Gmail (Google) is disabling Less Secure Apps. Zabbix mail don't work anymore

    XMLWordPrintable

Details

    Description

      From May 30, 2022, ​​Google no longer supports the use of third-party apps or devices which ask you to sign in to your Google Account using only your username and password which is defined as "Less Secure App" enabled in Google account. 

      Google gradually disable all accounts/domains with enabled less secure app option.

      So this means that classic username/password over TLS anymore doesn't work. Instead must be use oAuth2.0 token, MFA or Application password in place.

      As a result in Zabbix notifications, mail as media type, doesn't work anymore from Zabbix server

      535-5.7.8 Username and Password not accepted. Learn more at 535 5.7.8 https://support.google.com/mail/?p=BadCredentials bd13-20020a05651c168d00b0025076cd5ef9sm3621534ljb.128 - gsmtp

      I suggest make Zabbix email media type compatible with oAuth. It was asked already in 2015 in: ZBXNEXT-2979 . As I understand a special exclusion for Google Application password as option will not apply in Zabbix.

       

      Attachments

        Activity

          People

            zabbix.dev Zabbix Development Team
            radix Gatis Rumbens
            Votes:
            6 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

              Created:
              Updated: