ZABBIX BUGS AND ISSUES
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-2225

Incorrect linkage if templated items are used in graphs as Y axis min and max values

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.1
    • Fix Version/s: 1.8.2
    • Component/s: API (A), Server (S)
    • Labels:
      None

      Issue Links

        Activity

        Hide
        Alexander Vladishev added a comment -

        Fixed in server code in version pre1.8.2, rev. 11120.

        Show
        Alexander Vladishev added a comment - Fixed in server code in version pre1.8.2, rev. 11120.
        Hide
        richlv added a comment -

        confirming the fix in dev branch rev 11151.

        Show
        richlv added a comment - confirming the fix in dev branch rev 11151.
        Hide
        richlv added a comment -

        a problem was discovered - it is possible to choose items from other templates, and that can result in frontend errors.

        most likely when configuring a graph for a template, only items from the same template should be allowed to be chosen.

        additionally, even when that would be restricted, the following problem should still be fixed (users might have created such a configuration previously) :

        reset() expects parameter 1 to be array, boolean given[/usr/local/apache2/htdocs/dev/ZBX-2225-graph_maxi_inh/api/classes/class.cgraph.php:830]

        Show
        richlv added a comment - a problem was discovered - it is possible to choose items from other templates, and that can result in frontend errors. most likely when configuring a graph for a template, only items from the same template should be allowed to be chosen. additionally, even when that would be restricted, the following problem should still be fixed (users might have created such a configuration previously) : reset() expects parameter 1 to be array, boolean given [/usr/local/apache2/htdocs/dev/ZBX-2225-graph_maxi_inh/api/classes/class.cgraph.php:830]
        Hide
        richlv added a comment -

        dev branch rev 11168 - it is still possible to save graph with axis item refs to different templates.

        there should be api level checks that :

        1. if graph items are from a template, axis item references must be from the same template;
        2. axis item references can only be from a single template

        Show
        richlv added a comment - dev branch rev 11168 - it is still possible to save graph with axis item refs to different templates. there should be api level checks that : 1. if graph items are from a template, axis item references must be from the same template; 2. axis item references can only be from a single template
        Hide
        richlv added a comment -

        seems to work as expected in dev branch rev 11187

        Show
        richlv added a comment - seems to work as expected in dev branch rev 11187
        Hide
        Alexey Fukalov added a comment -

        branches/1.8 11189

        Show
        Alexey Fukalov added a comment - branches/1.8 11189
        Hide
        richlv added a comment -

        something went wrong with the merge or elsewhere - current trunk head fails with :

        [ CGraph::update ] Graph [ graph_upper ]: Incorrect item for Ymax value

        Show
        richlv added a comment - something went wrong with the merge or elsewhere - current trunk head fails with : [ CGraph::update ] Graph [ graph_upper ]: Incorrect item for Ymax value
        Hide
        richlv added a comment -

        confirming the fix in dev branch rev 11322.

        Show
        richlv added a comment - confirming the fix in dev branch rev 11322.
        Hide
        Alexey Fukalov added a comment -

        branches/1.8 11324

        Show
        Alexey Fukalov added a comment - branches/1.8 11324
        Hide
        Mischa Bachmann added a comment -

        I'm sorry but i don't quite understand the fix here. Is the fix applied in a dev branch wich will be released with 1.8.3?

        Show
        Mischa Bachmann added a comment - I'm sorry but i don't quite understand the fix here. Is the fix applied in a dev branch wich will be released with 1.8.3?
        Hide
        richlv added a comment -

        this particular issue should be fixed in 1.8.2, but there was another (less serious) problem with item references, which is fixed in svn head (and will be released as 1.8.3)

        Show
        richlv added a comment - this particular issue should be fixed in 1.8.2, but there was another (less serious) problem with item references, which is fixed in svn head (and will be released as 1.8.3)

          People

          • Assignee:
            Alexey Fukalov
            Reporter:
            Alexander Vladishev
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: