ZABBIX BUGS AND ISSUES

Can't copy SNMP items from one template to another

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Blocker Blocker
  • Resolution: Fixed
  • Affects Version/s: 1.8.2, 1.8.3
  • Fix Version/s: 1.8.9, 2.0.0
  • Component/s: None
  • Environment:
    RHEL5.5, PHP 5.1.6, Mysql 5.0.77
  • Zabbix ID:
    Reviewed 2.0

Description

We are trying to copy items from Template_Netscreen_25 template to our custom Juniper template. Copying icmp items succeeds, put copying snmp items gives an error: Incorrect key format 'key_name[param1,param2,...]'.
The same happens when trying to do a full clone of a template containing snmp items. We are running zabbix 1.8.2 and the problem still exists in 1.8.3 rev. 11623.
Since we are configuring templates on multiple nodes and for many devices, inserting all items manually isn't an option. Basically deploying zabbix in our environment is heavily dependent on that functionality. Thats why I set priority to Major.

Activity

richlv added a comment -

that's because item keys there contain colons. remove/replace them and it should work.

leaving this issue open to fix the default templates

richlv made changes -
Field Original Value New Value
Assignee richlv [ richlv ]
Rein Remmel added a comment -

Thanks,

renaming item keys resolved the problem.

Rein Remmel made changes -
Status Open [ 1 ] Confirmed [ 10000 ]
richlv added a comment -

template fixed for appliance 1.8.3, main data.sql won't be fixed until Zabbix 2.0

Alexei Vladishev made changes -
Fix Version/s 2.0 [ 10402 ]
Priority Major [ 3 ] Blocker [ 1 ]
Zabbix ID NA Reviewed 2.0
Alexei Vladishev made changes -
Labels database installation
Alexey Fukalov made changes -
Component/s GUI [ 10000 ]
Alexander Vladishev made changes -
Assignee richlv [ richlv ] Alexander Vladishev [ sasha ]
Alexander Vladishev made changes -
Status Confirmed [ 10000 ] In Progress [ 3 ]
Alexander Vladishev added a comment - - edited

Fixed in the development branches:
svn://svn.zabbix.com/branches/dev/ZBX-2361
svn://svn.zabbix.com/branches/dev/ZBX-2361-TRUNK

Alexander Vladishev made changes -
Status In Progress [ 3 ] Resolved [ 5 ]
Assignee Alexander Vladishev [ sasha ]
Fix Version/s 1.8.9 [ 10500 ]
Resolution Fixed [ 1 ]
Aleksandrs Saveljevs made changes -
Assignee Aleksandrs Saveljevs [ asaveljevs ]
Aleksandrs Saveljevs made changes -
Status Resolved [ 5 ] Tested [ 10002 ]
Assignee Aleksandrs Saveljevs [ asaveljevs ] Alexander Vladishev [ sasha ]
Alexander Vladishev added a comment -

Fixed in version pre-1.8.9, r22552.

Alexander Vladishev made changes -
Status Tested [ 10002 ] Closed [ 6 ]
Assignee Alexander Vladishev [ sasha ]

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: