ZABBIX BUGS AND ISSUES
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-3259

Log wizard error: Incorrect value for [ltype]

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.4rc2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      1. The trigger is made clicking icon of LogWizard from the item list screen.
      2. Screen of TriggerWizard displays the error.

        Issue Links

          Activity

          Konstantin Buravcov added a comment -

          Fixed in dev branch ZBX-3259

          It is now possible to use trigger wizard for any item with value_type=Log

          Oleksiy Zagorskyi added a comment -

          I think this one is duplicate of ZBX-3062
          It seems my requests often go unnoticed. Unfortunately.
          I must confess that I have to stop creating simple issue request, because you do not notice them, and then themselves faced with the problem and fix it.
          Sorry, IMHO.

          Konstantin Buravcov added a comment -

          Merged: branches/1.8 r15853

          Oleksiy Zagorskyi added a comment -

          Explain to me please why this form should be available only to the type of information "Log"?
          Compared to what it was before, it is even narrowing the scope of this form.
          I'm in my query the ZBX-3259 proposed doing well for the type of information, "text" and "character".
          Maybe for a "character" and do not need - at your decision, but for the "text" clearly, this form should be available!

          Konstantin Buravcov added a comment -

          Oleksiy, you are right, there is no reason not to use the same wizard for text and character values. You will find this fixed in 1.8.4 rev 15863

          Aleksandrs Saveljevs added a comment -

          (1) The popup says "Create trigger", but "Edit Trigger" - note the capitalization.

          (2) Since the trigger wizard is now also allowed for "Character" and "Text" items, the column should be renamed.

          Oleksiy Zagorskyi added a comment -

          About renaming column - I strongly suggest to just put an icon instead of the column name.
          The main advantage of the icons - this is column will narrow, resulting in more information from other columns will fit on the screen.
          I offered to make it a little earlier here https://support.zabbix.com/browse/ZBX-2630?focusedCommentId=34035&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_34035

          Remember that if the English word is short, then the other languages it can be long.

          Konstantin Buravcov added a comment -

          (1) Capitalization fixed;
          (2) 'Log' renamed to 'Wizard'.

          Oleksiy, thank you for the idea, but it was decided to leave column title as text for now for design consistency.

          richlv added a comment -

          i suspect that this has caused another problem. trunk rev 15967.

          try to add simple graph from dashboard to the favourites :

          Use of undefined constant S_LOG - assumed 'S_LOG'[/usr/local/apache2/htdocs/trunk/include/items.inc.php:104]

          Oleksiy Zagorskyi added a comment - - edited

          i find something interested. In pop-up try to select Edit trigger where is used for example function 'logseverity(0)' instead of 'regexp'

          Result ERROR in new window:
          Incorrect trigger expression. [logseverity0=2]
          Expression cannot be empty

          ... is bad
          On the idea that Wizard should be available only for the triggers with function 'regexp'.

          Aleksandrs Saveljevs added a comment - - edited

          (1) The S_LOG constant is already fixed in ZBX-1294 development branch, although it would be nice to fix this in the main branch as soon as possible.

          (2) The problem Oleksiy mentioned is a known one and is filed under ZBX-2640, point 2, as well as ZBX-2182.

          Aleksandrs Saveljevs added a comment -

          (3) Maybe we should have the icon centered?

          Konstantin Buravcov added a comment -
          • The S_LOG constant is already fixed in another issue and merged
          • It was decided that icon should not be centered
          richlv added a comment -

          confirming, S_LOG issue fixed in current trunk


            People

            • Assignee:
              Konstantin Buravcov
              Reporter:
              Konstantin Buravcov
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: