ZABBIX BUGS AND ISSUES
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-3532

impossible to add item to trigger expression from popup menu

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.8.5
    • Fix Version/s: 1.8.5
    • Component/s: Frontend (F)
    • Labels:
      None

      Description

      After fixed issue - ZBX-3411 fixed change trigger filter where change host

        Activity

        Alexey Pustovalov created issue -
        Alexey Pustovalov added a comment - - edited

        PS: not trigger. item into trigger expression!!

        Aleksandrs Saveljevs made changes -
        Field Original Value New Value
        Summary Impossible add trigger from popup menu impossible to add item to trigger expression from popup menu
        Affects Version/s 1.9.2 [ 10124 ]
        Priority Major [ 3 ] Blocker [ 1 ]
        Assignee Alexei Vladishev [ alexei ]
        Fix Version/s 1.9.2 [ 10124 ]
        Aleksandrs Saveljevs made changes -
        Project ZABBIX FEATURE REQUESTS [ 10144 ] ZABBIX BUGS AND ISSUES [ 10000 ]
        Key ZBXNEXT-659 ZBX-3532
        Workflow jira [ 20093 ] Zabbix workflow [ 20098 ]
        Affects Version/s 1.8.5 [ 10095 ]
        Affects Version/s 1.8.5 [ 10112 ]
        Fix Version/s 1.8.5 [ 10095 ]
        Fix Version/s 1.8.5 [ 10112 ]
        Component/s GUI [ 10000 ]
        Component/s GUI (configuration) [ 10080 ]
        Aleksandrs Saveljevs made changes -
        Status Open [ 1 ] Confirmed [ 10000 ]
        richlv added a comment -

        Event thread: click
        Error:
        name: TypeError
        message: Statement on line 16: The Object does not implement [[Call]]
        stacktrace: Line 16 of inline#3 script in http://host/1.8/popup.php?dstfrm=expression&dstfld1=itemid&dstfld2=description&submitParent=1&srctbl=items&srcfld1=itemid&srcfld2=description: In function addValues
        tmpStorage = $(parentDocumentForm[0]).select("#"+key).first();
        Line 1 of function script
        javascript: addValues('expression',

        {'itemid' : '22413','description' : 'ackmacros:ackmacro2'}

        , true); return false;
        ...

        Vladimir Barcevsky made changes -
        Assignee Vladimir Barcevsky [ vlad ]
        Vladimir Barcevsky made changes -
        Status Confirmed [ 10000 ] In Progress [ 3 ]
        Vladimir Barcevsky added a comment -

        fixed add item to trigger expression from popup menu
        svn://svn.zabbix.com/branches/dev/ZBX-3532

        Vladimir Barcevsky made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        richlv added a comment -

        no commits in the dev branch since its creation

        richlv made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        richlv made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        richlv added a comment - - edited

        works as expected in dev branch rev 17702.

        note that rev 17702 possibly introduced changes that might conflict with this branch

        edit : leaving issue as is for code review

        Alexey Fukalov added a comment -

        Fixed it in another way.
        Previously removed code can be useful in some situations.

        For trunk this will be fixed with ZBXNEXT-575.

        Vladimir Barcevsky added a comment -

        Merged branches, revision 17714,
        For trunk this will be fixed with ZBXNEXT-575.

        Vladimir Barcevsky made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        richlv added a comment -

        rev 17714 nuked the following changelog entry :

        • ZBX-3158 improved links in map element menu (Aly)

        i suspect that was not intended

        richlv made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Aleksandrs Saveljevs added a comment -

        Also, do not forget to add ZBX-3532 entry to the trunk's ChangeLog.

        Vladimir Barcevsky added a comment -

        Merged branches, revision 17737,
        Merged trunk, revision 17738

        Vladimir Barcevsky made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Aleksandrs Saveljevs made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Vladimir Barcevsky made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Alexei Vladishev made changes -
        Workflow Zabbix workflow [ 20098 ] Zabbix workflow - new [ 44668 ]

          People

          • Assignee:
            Vladimir Barcevsky
            Reporter:
            Alexey Pustovalov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: