ZABBIX BUGS AND ISSUES
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-3568

*UNKNOWN* value received if use macros in an item key

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.8.4
    • Fix Version/s: 1.8.5
    • Component/s: Server (S)
    • Labels:
      None

      Description

      Setting details:

      Hostname: localhost
      Item key: log[/var/log/

      {HOSTNAME}.log]
      Trigger: {localhost:log[/var/log/{HOSTNAME}

      .log].str(error)}=1

      Action message:

      {{HOSTNAME}:

      {TRIGGER.KEY}.last(#1)}
      {{HOSTNAME}:{TRIGGER.KEY}

      .last(#2)}
      {{HOSTNAME}:

      {TRIGGER.KEY}.last(#3)}
      {{HOSTNAME}:{TRIGGER.KEY}

      .last(#4)}
      {{HOSTNAME}:

      {TRIGGER.KEY}.last(#5)}


      Received:

      UNKNOWN
      UNKNOWN
      UNKNOWN
      UNKNOWN
      UNKNOWN

      It seems the problem is caused by escalator expands macros in item key's option.

      (1) Item key setting: log[/var/log/{HOSTNAME}.log]
      (2) Expand {TRIGGER.KEY}

      macro by escalator: log[/var/log/localhost.log]

      (1) and (2) is not equal, so escalater can not handle history data correctly.
      Actually, I added log[/var/log/localhost.log] item,
      events generated by log[/var/log/

      {HOSTNAME}

      .log] item used hisotry of log[/var/log/localhost.log].

        Issue Links

          Activity

          Alexander Vladishev added a comment - - edited

          The server side fixed in version pre1.8.5, r18088.

          richlv added a comment -

          could this be a duplicate of ZBX-3009 ?

          Alexander Vladishev added a comment -

          Yes, of course!

          Alexander Vladishev added a comment -

          Fixed in version pre1.8.5, r18258.


            People

            • Assignee:
              Unassigned
              Reporter:
              Alexander Vladishev
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: