ZABBIX BUGS AND ISSUES

Cannot add host from frontend

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Blocker Blocker
  • Resolution: Fixed
  • Affects Version/s: 1.9.9 (beta)
  • Fix Version/s: 2.0.0rc1
  • Component/s: Frontend (F)
  • Labels:
    None
  • Environment:
    rev 25069.
  • Zabbix ID:
    NA

Description

I'm trying add host and receive this errors:
Undefined variable: rows [include/triggers.inc.php:301]
Undefined variable: rows [include/triggers.inc.php:301]
Undefined variable: rows [include/triggers.inc.php:301]
Undefined variable: rows [include/triggers.inc.php:301]
Undefined variable: rows [include/triggers.inc.php:301]
Undefined variable: rows [include/triggers.inc.php:301]
Undefined variable: rows [include/triggers.inc.php:301]
Undefined variable: rows [include/triggers.inc.php:301]
mysql_real_escape_string() expects parameter 1 to be string, array given [include/db.inc.php:616]
mysql_real_escape_string() expects parameter 1 to be string, array given [include/db.inc.php:616]
Error in query [INSERT INTO auditlog_details (auditdetailid,auditid,table_name,field_name,oldvalue,newvalue) VALUES (5885,43941,'','hosts',Array,Array)] [Unknown column 'Array' in 'field list']

Issue Links

Activity

Hide
richlv added a comment -

most likely the same as ZBX-4596

Show
richlv added a comment - most likely the same as ZBX-4596
Hide
Oleksiy Zagorskyi added a comment -

I cannot reproduce it anyhow in r25095
Alexey, please describe details how you add the host.

Show
Oleksiy Zagorskyi added a comment - I cannot reproduce it anyhow in r25095 Alexey, please describe details how you add the host.
Hide
Alexey Pustovalov added a comment - - edited

try to clone host with templates

Show
Alexey Pustovalov added a comment - - edited try to clone host with templates
Hide
Alexey Pustovalov added a comment -

error is started receive after svn log -r25039
------------------------------------------------------------------------
r25039 | pavels | 2012-01-26 21:02:35 +0600 (Чтв, 26 Янв 2012) | 4 lines

..F....... ZBX-4558 added audit logging when udpating and creating triggers
A.F....... ZBX-4558 fixed deleting child template triggers when moving a trigger to a template
A......... ZBX-4558 fixed child template trigger attributes being reset when updating a template trigger
..F....... ZBX-4558 fixed trigger form "type" field value being inverted
------------------------------------------------------------------------

Show
Alexey Pustovalov added a comment - error is started receive after svn log -r25039 ------------------------------------------------------------------------ r25039 | pavels | 2012-01-26 21:02:35 +0600 (Чтв, 26 Янв 2012) | 4 lines ..F....... ZBX-4558 added audit logging when udpating and creating triggers A.F....... ZBX-4558 fixed deleting child template triggers when moving a trigger to a template A......... ZBX-4558 fixed child template trigger attributes being reset when updating a template trigger ..F....... ZBX-4558 fixed trigger form "type" field value being inverted ------------------------------------------------------------------------
Hide
Alexey Pustovalov added a comment - - edited

it is trouble saving in rev 25100.
Bug appears when trying add new host and with cloning hosts. New hosts must containing triggers.

Show
Alexey Pustovalov added a comment - - edited it is trouble saving in rev 25100. Bug appears when trying add new host and with cloning hosts. New hosts must containing triggers.
Hide
Oleksiy Zagorskyi added a comment -

The problem appears when I'm trying to link a template which has at least one trigger:

mysql_real_escape_string() expects parameter 1 to be string, array given [include/db.inc.php:616]
mysql_real_escape_string() expects parameter 1 to be string, array given [include/db.inc.php:616]
Error in query [INSERT INTO auditlog_details (auditdetailid,auditid,table_name,field_name,oldvalue,newvalue) VALUES (4085,210998,'','hosts',Array,Array)] [Unknown column 'Array' in 'field list']

And I cannot reproduce anyhow mentioned error: "Undefined variable: rows [include/triggers.inc.php:301]

Actually no problems with just host creation.

Show
Oleksiy Zagorskyi added a comment - The problem appears when I'm trying to link a template which has at least one trigger: mysql_real_escape_string() expects parameter 1 to be string, array given [include/db.inc.php:616] mysql_real_escape_string() expects parameter 1 to be string, array given [include/db.inc.php:616] Error in query [INSERT INTO auditlog_details (auditdetailid,auditid,table_name,field_name,oldvalue,newvalue) VALUES (4085,210998,'','hosts',Array,Array)] [Unknown column 'Array' in 'field list'] And I cannot reproduce anyhow mentioned error: "Undefined variable: rows [include/triggers.inc.php:301] Actually no problems with just host creation.
Hide
Pavels Jelisejevs added a comment - - edited

(1) Another problem caused by ZBX-4558: when cloning a host with templated triggers, these triggers are deleted from the original host.

<pavels> RESOLVED.
<Sasha> CLOSED

Show
Pavels Jelisejevs added a comment - - edited (1) Another problem caused by ZBX-4558: when cloning a host with templated triggers, these triggers are deleted from the original host. <pavels> RESOLVED. <Sasha> CLOSED
Hide
Pavels Jelisejevs added a comment -

RESOLVED.

Show
Pavels Jelisejevs added a comment - RESOLVED.
Hide
Oleksiy Zagorskyi added a comment - - edited

(2) I'm using this dev branch for usual work (because it works better than current trunk ) and I've observed one problem:
Open items list for some host, move mouse over "Triggers (1)" value in the Triggers column -> a tool-tip with the triggers details doesn't appear. On the mouse click doesn't appear too.
REOPENED.

<zalex> meh, the problem reproducible even on the rev 25142 (a base of copy this dev branch). This problem already fixed today in the trunk rev 25162.
Status changed to RESOLVED again.
CLOSED.

Show
Oleksiy Zagorskyi added a comment - - edited (2) I'm using this dev branch for usual work (because it works better than current trunk ) and I've observed one problem: Open items list for some host, move mouse over "Triggers (1)" value in the Triggers column -> a tool-tip with the triggers details doesn't appear. On the mouse click doesn't appear too. REOPENED. <zalex> meh, the problem reproducible even on the rev 25142 (a base of copy this dev branch). This problem already fixed today in the trunk rev 25162. Status changed to RESOLVED again. CLOSED.
Hide
Alexander Vladishev added a comment -

Successfully tested!

Show
Alexander Vladishev added a comment - Successfully tested!
Hide
Pavels Jelisejevs added a comment -

Merged to trunk r25260.

CLOSED.

Show
Pavels Jelisejevs added a comment - Merged to trunk r25260. CLOSED.
Hide
Alexey Serba added a comment -

Is there any workaround/patch to make "link template" working on 1.9.9 release?

Show
Alexey Serba added a comment - Is there any workaround/patch to make "link template" working on 1.9.9 release?
Hide
Oleksiy Zagorskyi added a comment -
Show
Oleksiy Zagorskyi added a comment - You may consider this page: http://www.zabbix.org/wiki/How_to/trunk_db_patches

People

Vote (0)
Watch (4)

Dates

  • Created:
    Updated:
    Resolved: