Uploaded image for project: 'ZABBIX FEATURE REQUESTS'
  1. ZABBIX FEATURE REQUESTS
  2. ZBXNEXT-5278

PHP config instructions incorrect for Ubuntu

    Details

    • Type: Change Request
    • Status: Open
    • Priority: Trivial
    • Resolution: Unresolved
    • Affects Version/s: 4.0.9
    • Fix Version/s: None
    • Component/s: Documentation (D)
    • Labels:
      None
    • Environment:
      Ubuntu (18.04)

      Description

      The PHP timezone must be configured before the user is able to start the zabbix server web interface. Both the instructions for Ubuntu on the Zabbix download page:

       

      https://www.zabbix.com/download?zabbix=4.0&os_distribution=ubuntu&os_version=18.04_bionic&db=mysql

       

      and within the manual:

       

      https://www.zabbix.com/documentation/4.0/manual/installation/install_from_packages/debian_ubuntu

       

      Are incorrect, for Ubuntu 18.04 at least but I suspect its wrong for all versions of Ubuntu. The current instructions tell the user to edit /etc/zabbix/apache.conf but the correct path of the file to edit is /etc/php/PHP_VERSION/apache2/php.ini. On my current Ubuntu 18.04 install the file to edit is /etc/php/7.2/apache2/php.ini . Apache needs to be restarted after editing this file, but that is already mentioned.

        Attachments

          Activity

            People

            • Assignee:
              martins-v Martins Valkovskis
              Reporter:
              danboid Dan MacDonald
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: