Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.0
    • Component/s: Frontend (F)
    • Labels:

      Description

      Edit form

        Issue Links

          Activity

          Eduards Samersovs created issue -
          Alexei Vladishev made changes -
          Field Original Value New Value
          Component/s Frontend (F) [ 10072 ]
          Component/s GUI (configuration) [ 10080 ]
          Eduards Samersovs made changes -
          Link This issue duplicates ZBX-3734 [ ZBX-3734 ]
          Pavels Jelisejevs added a comment - - edited

          (1) When creating a new node, the "Type" select doesn't have the "Master" option.

          <Eduard> RESOLVED

          <pavels> Now the "Master node" select is missing for child nodes.

          <Eduard> Because you don't have master yet..

          <pavels> But we should be able to add child nodes using the local node as the master.

          <Eduard> RESOLVED

          <pavels> CLOSED.

          Pavels Jelisejevs added a comment - - edited

          (2) When trying to create a node with the node id "0", the error message just says "ERROR: Cannot add node". I think we should add the "Warning. Incorrect value for field "ID"." message.

          <Eduard> RESOLVED

          <pavels> CLOSED.

          Alexei Vladishev added a comment - - edited

          (3) Unable to link 1500 or more hosts in Proxy management form.

          <Eduard> RESOLVED sorting, but actually can't repeat bug.

          <pavels> This seems to be caused by the max_input_vars parameter or it's Suhosin analog. It will be fixed as a separate issue. CLOSED.

          Pavels Jelisejevs added a comment - - edited

          (4) When I'm trying to edit a created node, the form looks weird. Note the error message, the duplicating "Name" fields and the "Master node" text. See https://support.zabbix.com/secure/attachment/18327/dm-node.png

          <Eduard> RESOLVED

          <pavels> We shouldn't be able to change the type of the node after it's created.

          <Eduard> RESOLVED

          <pavels> CLOSED.

          Pavels Jelisejevs made changes -
          Attachment dm-node.png [ 18327 ]
          Pavels Jelisejevs added a comment - - edited

          (5) When I'm trying to create a passive proxy with a DNS interface without a DNS address, an error occurs:

          Undefined index: 10173 [api/classes/CHostInterface.php:537]
          Interface with IP "127.0.0.1" cannot have empty DNS name while having "Use DNS" property on "". [CProxy.create -> CHostInterface.create -> CHostInterface.checkInput]

          Note, that the last message is missing the proxy name.

          <Eduard> RESOLVED

          <pavels> The same error message for hosts says "Interface with IP "127.0.0.1" cannot have empty DNS name while having "Use DNS" property on "%HOSTNAME%". Let's make it consistent.

          <Eduard> RESOLVED

          <pavels> CLOSED.

          Pavels Jelisejevs added a comment - - edited

          (6) When trying creating a proxy without a "Proxy name" the error message reads "Warning. Incorrect value for field "host".". It should be "Warning. Incorrect value for field "proxy name".".

          <Eduard> RESOLVED

          <pavels> CLOSED.

          <pavels> REOPENED: same thing when trying to create a proxy with an existing name: "Host "1" already exists."

          <Eduard> RESOLVED

          <pavels> CLOSED.

          Pavels Jelisejevs added a comment - - edited

          (7) History seems to be broken.

          <Eduard> RESOLVED

          <pavels> History is missing from Administration - General. This seems to have been broken in the trunk sometime earlier.

          <Eduard> RESOLVED

          <pavels> History should have a link to a specific configuration page, not just a single "Configuration of Zabbix" link.

          <Eduard> RESOLVED

          <pavels> I've changed the title of General / Other to "Other configuration parameters", it's more correct. CLOSED.

          Pavels Jelisejevs added a comment - - edited

          (8) The layout of administration/authentication and some other pages is broken in firefox https://support.zabbix.com/secure/attachment/18328/administration-authentication.png

          <Eduard> RESOLVED

          <pavels> CLOSED.

          Pavels Jelisejevs made changes -
          Attachment administration-authentication.png [ 18328 ]
          Pavels Jelisejevs added a comment - - edited

          (9) The navigation menu is missing from the graph, application and screen forms.

          <Eduard> Applications, Screens RESOLVED. For Graphs I will do it in ZBXNEXT-908, because most of code will be rewritten..

          <pavels> CLOSED.

          Pavels Jelisejevs added a comment - - edited

          (10) It would be really great, if your current location in the navigation menu would be either highlighted, or displayed as text instead of link.

          <Eduard> RESOLVED (current location will be without link)

          <pavels> Doesn't work in the list of discovery rules and item prototype form.

          <Eduard> RESOLVED, same as (14)

          <pavels> Noup, still doesn't work.

          <Eduard> RESOLVED

          <pavels> Still doesn't work in the item prototype form, and in the discrovery form items are highlighted instead of discoveries.

          <Eduard> RESOLVED

          <pavels> CLOSED.

          Pavels Jelisejevs added a comment - - edited

          (11) Since you've also fixed page headers, there's one small issue. The header on monitoring/events reads "HISTORY OF EVENTS ON 13 Mar 2012 15:48:42" while on the trigger status page - "STATUS OF TRIGGERS [13 Mar 2012 15:51:23]". It should be unified.

          <Eduard> RESOLVED

          <pavels> CLOSED.

          Pavels Jelisejevs added a comment - - edited

          (12) A couple of code issues:

          1. CDiscoveryRule already has a "selectPrototypes" option, there's no need for "selectItems";
          2. I suggest renaming CWarning::render() to show() to be consistent with other classes.

          <Eduard> RESOLVED

          <pavels> CLOSED.

          Eduards Samersovs made changes -
          Assignee Alexei Vladishev [ alexei ] Eduards Samersovs [ eduards ]
          richlv added a comment -

          apparently, the work is happening in svn://svn.zabbix.com/branches/dev/ZBXNEXT-914

          richlv added a comment - - edited

          (13) apparently the trailing dot is missing for "Incorrect interface port "10051eee" provided"

          <Eduard> RESOLVED

          <pavels> CLOSED.

          Oleksiy Zagorskyi added a comment - - edited

          (14) dev branch r26073 tested. When I click and open some discovery rule properties then I cannot click to a link "Item prototypes (2)" because it's not a hyper-link but just simple text.
          When I click to "Trigger prototypes (1)" or "Graph prototypes (1)" then i CAN click to "Item prototypes (2)"

          <Eduard> RESOLVED

          <zalex> Successful tested, CLOSED.

          Oleksiy Zagorskyi added a comment - - edited

          (15) according our discussion related to ZBX-3374 would be good to add additional link "<< Discovery rules list" prior the link "Discovery: <some name>"
          Then the ZBX-3374 will be fully resolved.

          <Eduard> RESOLVED
          <zalex> Successful tested, CLOSED.

          Eduards Samersovs made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 2.0.0rc2 (trunk) [ 11005 ]
          Resolution Fixed [ 1 ]
          Eduards Samersovs made changes -
          Assignee Eduards Samersovs [ eduards ] Pavels Jelisejevs [ jelisejev ]
          Pavels Jelisejevs made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Assignee Pavels Jelisejevs [ jelisejev ] Eduards Samersovs [ eduards ]
          Pavels Jelisejevs added a comment - - edited

          (16) The node select is missing from the top of the page.

          <Eduard> RESOLVED

          <pavels> CLOSED.

          Pavels Jelisejevs added a comment - - edited

          (17) A "S_STATUS_OF_ZABBIX" string appears in the history.

          <Eduard> Seems it was saved in your profile, please re-test it now..

          <pavels> Yep, it's ok now. CLOSED.

          Eduards Samersovs made changes -
          Link This issue is duplicated by ZBX-3266 [ ZBX-3266 ]
          Eduards Samersovs made changes -
          Assignee Eduards Samersovs [ eduards ] Pavels Jelisejevs [ jelisejev ]
          Eduards Samersovs made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Pavels Jelisejevs made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Assignee Pavels Jelisejevs [ jelisejev ] Eduards Samersovs [ eduards ]
          Eduards Samersovs made changes -
          Assignee Eduards Samersovs [ eduards ] Pavels Jelisejevs [ jelisejev ]
          Pavels Jelisejevs added a comment - - edited

          (18) Please review my changes in r26175.

          <Eduard> Ok, CLOSED

          Pavels Jelisejevs made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Pavels Jelisejevs added a comment -

          TESTED.

          Pavels Jelisejevs made changes -
          Status Resolved [ 5 ] Tested [ 10002 ]
          Assignee Pavels Jelisejevs [ jelisejev ] Eduards Samersovs [ eduards ]
          Pavels Jelisejevs made changes -
          Status Tested [ 10002 ] Reopened [ 4 ]
          Pavels Jelisejevs made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Pavels Jelisejevs made changes -
          Status Resolved [ 5 ] Tested [ 10002 ]
          Eduards Samersovs added a comment -

          trunk r.26226 version 2.0.0.rc2

          Eduards Samersovs made changes -
          Status Tested [ 10002 ] Closed [ 6 ]
          Alexander Vladishev made changes -
          Fix Version/s 2.0.0 [ 10062 ]
          Fix Version/s 2.0.0rc2 [ 11005 ]
          richlv added a comment - - edited

          interestingly, this has broken map editing in opera (11.61, linux)

          adding a new element now fails. error console just reports : "Syntax error at line 1 in event handler: expected expression, got <end of file>"

          this was broken in revision r26226

          <Eduard> RESOLVED in ZBXNEXT-908 (r.26791)

          <richlv> problem gone in the dev branch, rev 26799; leaving as is for code review

          richlv made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          richlv made changes -
          Labels distributed
          Eduards Samersovs made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Assignee Eduards Samersovs [ eduards ] richlv [ richlv ]
          Resolution Fixed [ 1 ]
          richlv made changes -
          Assignee richlv [ richlv ]
          Eduards Samersovs made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Alexander Vladishev made changes -
          Workflow ZBXNEXT workflow [ 22541 ] Zabbix workflow [ 32416 ]
          Alexei Vladishev made changes -
          Workflow Zabbix workflow [ 32416 ] Zabbix workflow - new [ 39750 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Eduards Samersovs
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: