Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.8.8
    • Fix Version/s: None
    • Component/s: Frontend (F)
    • Labels:
      None

      Description

      Add a check to verify if Zabbix server is running.
      The only cange could be adding the lines:

      if(!fsockopen($ZBX_SERVER, $ZBX_SERVER_PORT, $errnum, $errstr, 2))

      { unset($show_warning); include_once('warning.php'); }

      after
      require_once('include/config.inc.php');
      in dashboard.php

        Issue Links

          Activity

          richlv added a comment -

          could you please clarify what is the functional goal ?

          Nicola Canepa added a comment -

          The goal is to be visually notified when the zabbix_server is down from the web GUI.
          The little "server is running" in "Status of Zabbix" is not enough, for such a bad event in my opinion.
          Maybe a change of color somewhere could be enough.

          richlv added a comment -

          ok, then it's a dupe of ZBXNEXT-829


            People

            • Assignee:
              Alexei Vladishev
              Reporter:
              Nicola Canepa
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: