Details

      Description

      Zabbix 1.8 required PHP 5.0 or later, but several files does not correspond to the syntax of PHP 5.0:

      • include/triggers.inc.php
      • include/func.inc.php
      • include/classes/class.cvalidator.php
      • include/maps.inc.php
      • include/hosts.inc.php
      • api/classes/class.cmaintenance.php
      • api/classes/class.cscreenitem.php
      • api/classes/class.citem.php
      • api/classes/class.chost.php

      Error message:

      Parse error: parse error, unexpected T_ARRAY, expecting '&' or T_VARIABLE in include/triggers.inc.php on line 2723
      Errors parsing include/triggers.inc.php
      

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              sasha Alexander Vladishev
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: