Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-10710

system.cpu.util show incorrect utilization

    XMLWordPrintable

    Details

    • Type: Problem report
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 3.0.2
    • Component/s: Agent (G)
    • Labels:
      None
    • Environment:
    • Team:
      Team A
    • Sprint:
      Sprint 19, Sprint 20, Sprint 21
    • Story Points:
      6

      Description

      The zabbix agent send incorrect utilization of cpu which twice less than output of top command:

      On agent server:

      [[email protected]]# top|grep Cpu
      %Cpu(s): 84.6 us,  8.3 sy,  0.0 ni,  5.5 id,  0.0 wa,  0.0 hi,  1.6 si,  0.0 st
      %Cpu(s): 82.8 us,  8.7 sy,  0.0 ni,  6.9 id,  0.0 wa,  0.0 hi,  1.6 si,  0.0 st
      %Cpu(s): 84.9 us,  9.4 sy,  0.0 ni,  4.0 id,  0.0 wa,  0.0 hi,  1.7 si,  0.0 st
      %Cpu(s): 82.7 us,  9.1 sy,  0.0 ni,  6.5 id,  0.0 wa,  0.0 hi,  1.7 si,  0.0 st
      %Cpu(s): 84.1 us,  8.1 sy,  0.0 ni,  6.0 id,  0.1 wa,  0.0 hi,  1.7 si,  0.0 st
      %Cpu(s): 84.9 us,  8.1 sy,  0.0 ni,  5.6 id,  0.0 wa,  0.0 hi,  1.4 si,  0.0 st
      %Cpu(s): 84.3 us,  7.9 sy,  0.0 ni,  6.2 id,  0.0 wa,  0.0 hi,  1.6 si,  0.0 st
      

      At the same time on zabbix server:

      [[email protected] bin]# zabbix_get -sxxx -p10050 -k system.cpu.util[]
      49.139935
      [[email protected] bin]# zabbix_get -sxxx -p10050 -k system.cpu.util[,user]
      49.171261
      [[email protected] bin]# zabbix_get -sxxx -p10050 -k system.cpu.util[,system]
      4.926904
      
      [[email protected] bin]# zabbix_get -sxxx -p10050 -k system.cpu.util[]
      49.079076
      [[email protected] bin]# zabbix_get -sxxx -p10050 -k system.cpu.util[,user]
      49.082120
      [[email protected] bin]# zabbix_get -sxxx -p10050 -k system.cpu.util[,system]
      4.890176
      

      And the same incorrect values for another server:

      [[email protected] ~]# top|grep Cpu
      %Cpu(s): 96.6 us,  2.7 sy,  0.0 ni,  0.1 id,  0.0 wa,  0.0 hi,  0.6 si,  0.0 st
      %Cpu(s): 96.5 us,  2.8 sy,  0.0 ni,  0.2 id,  0.0 wa,  0.0 hi,  0.5 si,  0.0 st
      %Cpu(s): 96.3 us,  3.0 sy,  0.0 ni,  0.1 id,  0.0 wa,  0.0 hi,  0.6 si,  0.0 st
      %Cpu(s): 94.3 us,  4.6 sy,  0.0 ni,  0.3 id,  0.0 wa,  0.0 hi,  0.7 si,  0.0 st
      %Cpu(s): 96.2 us,  2.7 sy,  0.0 ni,  0.2 id,  0.0 wa,  0.0 hi,  1.0 si,  0.0 st
      %Cpu(s): 96.2 us,  2.7 sy,  0.0 ni,  0.4 id,  0.0 wa,  0.0 hi,  0.7 si,  0.0 st
      %Cpu(s): 95.2 us,  2.9 sy,  0.0 ni,  1.1 id,  0.0 wa,  0.0 hi,  0.7 si,  0.0 st
      %Cpu(s): 95.9 us,  2.7 sy,  0.0 ni,  0.7 id,  0.0 wa,  0.0 hi,  0.6 si,  0.0 st
      %Cpu(s): 96.4 us,  2.6 sy,  0.0 ni,  0.5 id,  0.0 wa,  0.0 hi,  0.5 si,  0.0 st
      
      [[email protected] bin]# zabbix_get -sxxx2 -p10050 -k system.cpu.util[]
      49.773875
      [[email protected] bin]# zabbix_get -sxxx2 -p10050 -k system.cpu.util[,user]
      49.734167
      [[email protected] bin]# zabbix_get -sxxx2 -p10050 -k system.cpu.util[,system]
      1.461466
      
      [[email protected] bin]# zabbix_get -sxxx2 -p10050 -k system.cpu.util[]
      49.714295
      [[email protected] bin]# zabbix_get -sxxx2 -p10050 -k system.cpu.util[,user]
      49.711913
      [[email protected] bin]# zabbix_get -sxxx2 -p10050 -k system.cpu.util[,system]
      1.471862
      

      In attach the screenshot for cpu.util from this 2 servers.
      I can reproduce this also in anouther servers, not only this 2

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              valdis Valdis Kauń∑is (Inactive)
              Reporter:
              dmizyk Dmitry Zykov
              Votes:
              1 Vote for this issue
              Watchers:
              9 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: