Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-11053

Time filter settings are lost when paging on Events page

    XMLWordPrintable

    Details

    • Type: Incident report
    • Status: Closed
    • Priority: Trivial
    • Resolution: Duplicate
    • Affects Version/s: 3.0.3, 3.0.4
    • Fix Version/s: None
    • Component/s: Frontend (F)
    • Labels:
      None

      Description

      On the Monitoring / Events page set the time filter to a duration with lots of events, so the paging controls appear on the bottom. Make sure that the shown time interval starts and ends in the past.
      The url is like this, showing the configured time filter:
      https://server/zabbix/events.php?fullscreen=0&groupid=0&hostid=0&page=1&sid=e028dec30c14c88a&period=86400&stime=20160730000000
      In my example there were 500 events on that day. Now when I click to change the page to page 4, the time filter parameters period and stime are lost from the url, and the time filter jumps to present.
      The url becomes this:
      https://server/zabbix/events.php?fullscreen=0&groupid=0&hostid=0&page=4
      instead of:
      https://server/zabbix/events.php?fullscreen=0&groupid=0&hostid=0&page=4&sid=e028dec30c14c88a&period=86400&stime=20160730000000

      I have seen this in 3.0.3 and 3.0.4 with Firefox and Chrome too.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              kz282_3 Zoltan Kovacs
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: