Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-11741

install zabbix-web-mysql should recognize php-sql or php-mysqlnd

    XMLWordPrintable

Details

    • Incident report
    • Status: Closed
    • Blocker
    • Resolution: Won't fix
    • 3.2.3
    • None
    • Installation (I)
    • None
    • Centos 7 with PHP7

    Description

      Tried to install but getting error

      yum install zabbix-server-mysql zabbix-web-mysql
      Loaded plugins: fastestmirror
      Loading mirror speeds from cached hostfile

      • base: mirror.1000mbps.com
      • epel: mirror.1000mbps.com
      • extras: mirror.1000mbps.com
      • remi: nl.mirror.babylon.network
      • remi-php70: nl.mirror.babylon.network
      • remi-safe: nl.mirror.babylon.network
      • updates: centos.mirror.triple-it.nl
        Resolving Dependencies
        --> Running transaction check
        ---> Package zabbix-server-mysql.x86_64 0:3.2.3-1.el7 will be installed
        .............
        --> Processing Dependency: php-mysql for package: zabbix-web-mysql-3.2.3-1.el7.noarch
        Package php-mysql-5.4.45-12.el7.remi.x86_64 is obsoleted by php-mysqlnd-7.0.15-1.el7.remi.x86_64 which is already installed
        --> Finished Dependency Resolution
        Error: Package: zabbix-web-mysql-3.2.3-1.el7.noarch (zabbix)
        Requires: php-mysql
        Available: php-mysql-5.4.16-42.el7.x86_64 (base)
        php-mysql = 5.4.16-42.el7
        Available: php-mysql-5.4.45-11.el7.remi.x86_64 (remi)
        php-mysql = 5.4.45-11.el7.remi
        Available: php-mysql-5.4.45-12.el7.remi.x86_64 (remi)
        php-mysql = 5.4.45-12.el7.remi
        Available: php-mysqlnd-5.4.16-42.el7.x86_64 (base)
        php-mysql = 5.4.16-42.el7
        Available: php-mysqlnd-5.4.45-11.el7.remi.x86_64 (remi)
        php-mysql = 5.4.45-11.el7.remi
        Available: php-mysqlnd-5.4.45-12.el7.remi.x86_64 (remi)
        php-mysql = 5.4.45-12.el7.remi
        Available: php-pecl-mysql-1.0.0-0.8.20151007git294ce3b.el7.remi.7.0.x86_64 (remi-php70)
        php-mysql = 1:1.0.0
        Available: php-pecl-mysql-1.0.0-0.9.20151007git294ce3b.el7.remi.7.0.x86_64 (remi-php70)
        php-mysql = 1:1.0.0
        Installed: php-mysqlnd-7.0.15-1.el7.remi.x86_64 (@remi-php70)
        Not found
        Available: php-mysqlnd-7.0.14-1.el7.remi.x86_64 (remi-php70)
        Not found
        You could try using --skip-broken to work around the problem
        You could try running: rpm -Va --nofiles --nodigest

      package php-mysqlnd-7.0.15- is installed.

      Attachments

        Activity

          People

            Unassigned Unassigned
            erald1956 erald de Hoog
            Votes:
            2 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: