Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-11917

Red Hat 7 agent broken

    XMLWordPrintable

Details

    • Incident report
    • Status: Closed
    • Critical
    • Resolution: Incomplete
    • 3.2.4
    • None
    • Agent (G)
    • None
    • Red Hat 7

    Description

      The agent for Red Hat 7 for 3.2.x is completely broken. I tried 3.2.4, I then removed and reverted to 3.2.0, same problem. I reverted back down all the way to 2.4.8 which we had running previously and it still runs fine. I'll also note that the 3.2.4 agent runs fine on Red Hat 6, so this is strictly an issue with the 7 agents for some reason (http://repo.zabbix.com/zabbix/3.2/rhel/7/x86_64/)

      3.2.4 simply fails to start giving this status output:

      zabbix-agent.service - Zabbix Agent
      Loaded: loaded (/usr/lib/systemd/system/zabbix-agent.service; disabled; vendor preset: disabled)
      Active: activating (auto-restart) (Result: resources) since Tue 2017-03-14 18:22:42 EDT; 9s ago
      Process: 10533 ExecStop=/bin/kill -SIGTERM $MAINPID (code=exited, status=1/FAILURE)
      Process: 10678 ExecStart=/usr/sbin/zabbix_agentd -c $CONFFILE (code=exited, status=0/SUCCESS)
      Main PID: 10531 (code=exited, status=1/FAILURE)

      Mar 14 18:22:42 aawebapps systemd[1]: zabbix-agent.service never wrote its PID file. Failing.
      Mar 14 18:22:42 aawebapps systemd[1]: Failed to start Zabbix Agent.
      Mar 14 18:22:42 aawebapps systemd[1]: Unit zabbix-agent.service entered failed state.
      Mar 14 18:22:42 aawebapps systemd[1]: zabbix-agent.service failed.

      Under 3.2.0 it was slightly different:

      zabbix-agent.service - Zabbix Agent
      Loaded: loaded (/usr/lib/systemd/system/zabbix-agent.service; disabled; vendor preset: disabled)
      Active: activating (auto-restart) (Result: resources) since Tue 2017-03-14 18:32:22 EDT; 5s ago
      Process: 10950 ExecStart=/usr/sbin/zabbix_agentd -c $CONFFILE (code=exited, status=0/SUCCESS)

      Mar 14 18:32:22 aawebapps systemd[1]: zabbix-agent.service never wrote its PID file. Failing.
      Mar 14 18:32:22 aawebapps systemd[1]: Failed to start Zabbix Agent.
      Mar 14 18:32:22 aawebapps systemd[1]: Unit zabbix-agent.service entered failed state.
      Mar 14 18:32:22 aawebapps systemd[1]: zabbix-agent.service failed.

      Attachments

        Activity

          People

            Unassigned Unassigned
            ebonweaver Ebonweaver
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: