In include/perfmon.h there is a definition of an enum type without a name:
and hence these values need to be stored in a generic int:
Would be so much better for readability to give this type a meaningful name.
P.S. Also struct type naming does not follow the latest guidelines.