Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-12845

Configuration of Web-frontend fails with zabbix-server-pgsql on Ubuntu 16.04 with installation from packages

    XMLWordPrintable

Details

    • Documentation task
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 3.0.11
    • 4.0 (plan)
    • Installation (I)
    • None
    • Fresh installed Ubuntu 16.04 (3)
    • Team C
    • Sprint 18, Sprint 19
    • 1

    Description

      Hey,

      i found some issues with the package based installation of zabbix 3.0.11 on Ubuntu 16.04. I had chosen pgsql and webfrontend, like noted in Zabbix 3.0 Documentation. php-bcmath, php-mbstring and php-xml are not in required packages for frontend when installing via apt, this should be changed. Additionally php-pgsql is not in required packages for zabbix-server-pgsql, which causes frontend initialization to fail, because pgsql is not chooseable as database engine.

      Additionally database schema does not fit, as frontend initialization fails because of wrong database schema. Fixed it, with dropping database and recreating schema and data with sql scripts from 3.0.11 sources.

      Its just a kind of comfort-issue, but misleads, as some of these points aren't documented in official documentation.

      Kind regards
      Jakob

      Attachments

        Activity

          People

            dimir dimir
            b.serverbetrieb B.Serverbetrieb
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: