Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-14543

Install Zabbix 3.4 on standalone machine from rpm -- mariadb-libs-5.5.56-2.el17.x86_64 conflicts with zabbix-server-mysql-3.4.11-1.el7.x86_64

    XMLWordPrintable

    Details

    • Type: Incident report
    • Status: Closed
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.4.11
    • Fix Version/s: None
    • Component/s: Server (S)
    • Labels:
    • Environment:
      Centos 7

      Description

      I am installing Zabbix 3.4 on a set of secured Centos 7 systems behind a firewall with no internet access.

      I am directly installing at the command line from the rpm files.

      I have installed mysql from the rpm files and am able to get into mysql from the command line.

      I have installed all the prerequisite php and other packages - leaving only zabbix-server-mysql to install.

      As shown in the screenshot, zabbix-server-mysql fails wanting libmysqlclient.so.18 installed - which is a part of the mariadb-libs.

      When I try to install the two together, I am told that mariadb-libs is obsoleted by the already installed mysql-community-libs .

      So I am stuck - mariadb is both required and obsoleted at the same time.  How do I get around this given I only have the command line and rpm files at my disposal?

       

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            jjerpseth James Jerpseth
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: