Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-14940

Upgrade from 4.0rc* to 4.0 (final) is not offered on Ubuntu using packet repositories

    Details

    • Type: Problem report
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 4.0.0rc3, 4.0.0
    • Fix Version/s: 4.2.0alpha1
    • Component/s: Packages (C)
    • Labels:
      None
    • Environment:
      Ubuntu 14.04 LTS
    • Team:
      Team I
    • Sprint:
      Sprint 44, Sprint 45, Sprint 46, Nov 2018, Sprint 47, Dec 2018, Sprint 48, Jan 2019, Sprint 49 (Feb 2019), Sprint 50 (Mar 2019), Sprint 51 (Apr 2019)
    • Story Points:
      2

      Description

      Steps to reproduce:

      1. Have an Ubuntu Server with the 3.5 version of the zabbix-release package installed
      2. Install package zabbix-release_4.0-2+xenial_all.deb
      3. apt update
      4. apt upgrade zabbix-server-mysql

       

      Result:

      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      zabbix-server-mysql is already the newest version (1:4.0.0rc3-1+xenial).
      Calculating upgrade... Done
      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

      Expected:
      Upgrade to 4.0.0 should be offered. Apparently apt doesn't recognize 4.0.0 is actually NEWER than 4.0rc*...

       

        Attachments

          Activity

            People

            • Assignee:
              dimir dimir
              Reporter:
              christiananton Christian Anton
            • Votes:
              7 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: