Details

    • Type: Incident report
    • Status: Closed
    • Priority: Trivial
    • Resolution: Won't fix
    • Affects Version/s: 4.0.1
    • Fix Version/s: None
    • Component/s: Templates (T)
    • Environment:
      Windows 2012, but reproduce on Linux agent too

      Description

      Steps to reproduce:

      1. Changes in configuration...

      A template is in attachment. Its a COL_SrvWebLog item with preprocessing

      The Regular expression is named @ExtractLogWCF and its definition:

      (^[0-9]\{4}-[0-9]\{2}-[0-9]\{2}\s[0-9]\{2}:[0-9]\{2}:[0-9]\{2}.[0-9]\{4})\|.*Async\|(.*)\s-\s(Response|Request).*

      Result:

      In a file, I have this lines:

      |
      2018-12-12 18:27:48.9934|DEBUG|Neo.WebApiServiceHost.WebApiLoggingHandler-SendAsync|1d138046-7edf-4ab0-bc20-7bf6353e3c77 - Response:
      200 OK
      Headers:
      Content-Type: application/json; charset=utf-8
      Content:
      \{"alnovaExternalID":"NZ7BY4989C0","name":"AGNES","secondName":"CAROLINE","usedName":"AGI","surname":"WITYK","email":"[email protected]","dateOfBirth":"1980-09-12","IBAN":"FR7616908000010200000023301"}
      |

      When the regular expression is applied to the line with just the pipe character, I obtain a not suuported item with the message:

      Item preprocessing step #1 failed: cannot perform regular expression match on value "|" of type "string": pattern does not match

      I think it's a problem with a single line with just a pipe character

      Regards

        Attachments

          Activity

            People

            Assignee:
            ArtursL Arturs Lontons
            Reporter:
            fhmailliet MAILLIET François-Hugues
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: