Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-15411

Compilation for zabbix-agent Fails on Solaris 11.11

    Details

    • Type: Problem report
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.0.2
    • Fix Version/s: None
    • Component/s: Agent (G)
    • Labels:
      None

      Description

      Steps to reproduce:

      Download 4.0.2 to Solaris 11 box 

      Try to compile agents using ./configure --enable agents

      Encounter the following error

      config.log 

      checking for libpcre support... no
      configure: error: Unable to use libpcre (libpcre check failed)

      This only occurs with building the agent --enable-agent when giving just a configure. pcre and pcre2 are installed as is gcc and make.

       

      Seeing other failures and errors for GCC and libraries missing.

      Is 4.0.2 supported on uname -a (SunOS 5.11 11.4.4.4.0 sun4v sparc sun4v)

      Perhaps there are environmental things that can be reviewed.

      Log attached. 

      Thanks in advance

       

      1. Changes in configuration...
      2. Navigate to screen title...
      3. Click on screen element...
      4. ...

      Result:
      See screenshot...
      See log file...
      See memory dump...
      Expected:
      See screenshot....
      See attached patch file...

        Attachments

          Activity

            People

            • Assignee:
              zabbix.support Zabbix Support Team
              Reporter:
              michael.colletti Michael Colletti
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: