Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-15626

Hosts being rediscovered

    XMLWordPrintable

    Details

    • Type: Problem report
    • Status: Closed
    • Priority: Trivial
    • Resolution: Won't fix
    • Affects Version/s: 4.0.4
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Since upgrading to Zabbix 4.0 we're experiencing odd behavior in regards to Auto Registration. 
      By default, we do not pre-create Zabbix hosts but let the agent register them. Afterwards we link the templates and it's done. Discovered hosts are placed into the "Discovered Hosts" group and this group has a permanent maintenance period preventing alerts from going out.

      However, since 4.0 some hosts are being re-discovered once in a while.
      It may be that that zabbix-agent upgrades are the cause of this.
      When we upgraded from 3.4 to 4.0 basically every host ended up in the "Discovered Hosts" group, so we assumed it was because of that. However, we've been using 4.0 for some time now and hosts keep on ending up in this group.

      Skimming through the changelog it may have something to do with ZBXNEXT-2365.
      These hosts have kernel version mentioned in the OS field in Host Inventory.

      So it seems that every time we upgrade kernels, hosts are being "Auto Registered" again and are then again moved to the Discovered group as a result? Is there a way to disable this since it is not very practical and would make the Auto Registration pretty much useless, since it causes our hosts to end up not being monitored.

        Attachments

          Activity

            People

            Assignee:
            ArtursL Arturs Lontons
            Reporter:
            frank Frank
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: