Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-16028

Zabbix agent 4.0.7 and 4.2.1 breaks support for libzbxpgsql.so

    Details

    • Type: Problem report
    • Status: Closed
    • Priority: Blocker
    • Resolution: Won't fix
    • Affects Version/s: 4.2.0
    • Fix Version/s: None
    • Component/s: Agent (G)
    • Labels:
      None

      Description

      Steps to reproduce:

      1. Upgrade the zabbix agent to 4.0.7
      2. (Try to) start the agent.
      3. Check the zabbix agent logfile

      Result:

       14538:20190419:094458.679 Starting Zabbix Agent [staging]. Zabbix 4.0.7 (revision 92831).
       14538:20190419:094458.679 **** Enabled features ****
       14538:20190419:094458.679 IPv6 support: YES
       14538:20190419:094458.679 TLS support: YES
       14538:20190419:094458.679 **************************
       14538:20190419:094458.679 using configuration file: /etc/zabbix/zabbix_agentd.conf
       14538:20190419:094458.681 cannot load module "libzbxpgsql.so": /usr/lib64/zabbix/modules/libzbxpgsql.so: undefined symbol: __zbx_zbx_snprintf
       14538:20190419:094458.681 loading modules failed, exiting...
      

      Expected:
      No error and zabbix agent starting up as usual.

        Attachments

          Activity

            People

            • Assignee:
              ArtursL Arturs Lontons
              Reporter:
              Neighbour Herbert Buurman
            • Votes:
              1 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: