Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-16807

Remote command during Auto-registration

    XMLWordPrintable

    Details

    • Type: Incident report
    • Status: Need info
    • Priority: Trivial
    • Resolution: Unresolved
    • Affects Version/s: 4.0.13
    • Fix Version/s: None
    • Component/s: Server (S)
    • Environment:
      Zabbix Server & agents 4.0.8
      RH7.2 Enterprise
    • Team:
      Team A
    • Sprint:
      Sprint 58 (Nov 2019), Sprint 59 (Dec 2019), Sprint 60 (Jan 2020), Sprint 61 (Feb 2020), Sprint 62 (Mar 2020), Sprint 63 (Apr 2020), Sprint 64 (May 2020), Sprint 65 (Jun 2020), Sprint 66 (Jul 2020)

      Description

      When doing remote command for an auto-registred agent with a non-default port, Server tries to remote command on the default port 10050 instead of the customized Port.

      Below is the agent conf file.

      1. configuration v4.0.8
        PidFile=/opt/XXX10/Logiciel/ZABXAGENT/run/zabbix_agentd_v4.pid
        LogFile=/opt/XXX10/Logiciel/ZABXAGENT/log/zabbix_agentd_v4.log
        EnableRemoteCommands=1
        LogRemoteCommands=0
        LogFileSize=256
        Server=10.166.179.177,10.166.179.178,xxxx,xxxx
        ListenPort=20050
        ServerActive=10.166.179.179
        LoadModulePath=/opt/ZAR10/Logiciel/ZABXAGENT/etc/zabbix/modules
        LoadModule=zabbix_module_load.so
        HostMetadata=USINE,LINUX
        HostMetadataItem=system.run[cat /opt/XXX/Logiciel/ZABXAGENT/etc/zabbix/hostmetadata.conf]
        Hostname=TOTO

      Thanks for your status
      Alain

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              zabbix.dev Zabbix Development Team
              Reporter:
              alain ganuchaud Alain Ganuchaud
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated: