Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-16841

proc_info[process,gdiobj(or userobj)] returns 0 in some case

    XMLWordPrintable

Details

    • Incident report
    • Status: Confirmed
    • Trivial
    • Resolution: Unresolved
    • 3.0.28, 4.0.14
    • None
    • Agent (G), Server (S)
    • None
    • Windows2008R2,Windows2016,Windows10
    • Team B
    • Sprint 58 (Nov 2019), Sprint 59 (Dec 2019), Sprint 60 (Jan 2020), Sprint 61 (Feb 2020), Sprint 62 (Mar 2020), Sprint 63 (Apr 2020), Sprint 64 (May 2020), Sprint 65 (Jun 2020), Sprint 66 (Jul 2020), Sprint 67 (Aug 2020), Sprint 68 (Sep 2020), Sprint 69 (Oct 2020), Sprint 70 (Nov 2020), Sprint 71 (Dec 2020), Sprint 72 (Jan 2021), Sprint 73 (Feb 2021), Sprint 74 (Mar 2021), Sprint 75 (Apr 2021), Sprint 76 (May 2021), Sprint 77 (Jun 2021), Sprint 78 (Jul 2021), Sprint 79 (Aug 2021), Sprint 80 (Sep 2021), Sprint 81 (Oct 2021), Sprint 82 (Nov 2021), Sprint 83 (Dec 2021)
    • 2

    Description

      Steps to reproduce:

      • zabbix_agentd -t proc_info[iexplore.exe,gdiobj] returns ordinary value like below.
      • but zabbix_get and zabbix GUI always return 0 like below.
         
      • AFAIK only processes that do not run as SYSTEM user(like iexplore.exe,explorer.exe etc) have above problem and if run zabbix_agentd foreground zabbix_get can get ordinary value even though processes run as NOT SYSTEM user like below.
         
         
        Expected:
        zabbix_get can get ordinary value whether processes run as SYSTEM user or not.
         

      Attachments

        Activity

          People

            zabbix.dev Zabbix Development Team
            yIn Syusei YIn
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated: