Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-17340

Zabbix Trigger item value is incorrect on problem state

    XMLWordPrintable

Details

    • Problem report
    • Status: Closed
    • Trivial
    • Resolution: Duplicate
    • None
    • None
    • None
    • None

    Description

      Steps to reproduce:

      1. Create a trigger expression for number of running processes for Linux. Example using average trigger function and value greater than 30 --> _ {[FQDN_OR_IP_HOST:proc.num[,,run]|https://zabbix.eng.citrite.net/items.php?form=update&itemid=397217].*avg(*5m*)*}

        >30_.

      2. Create a Zabbix Action and include the Zabbix Macro {ITEM.VALUE1}.
      3. When the trigger is fired the item value is incorrectly displayed.

      This happens rarely but believe this might either be using the wrong macro or a potential bug.

      I wanted to get clarity on this and whether this has been seen before.

      I am using Zabbix version 4.0.15 on Debian 9 OS with partitioned (pg_partman) PostgreSQL v11.4 database.

      Result: The Zabbix Item Value in the Action displays a wrong value; happens rarely. See attached screenshots.
      Expected: To see the proper item value when the trigger fires.

      Attachments

        Issue Links

          Activity

            People

              edgar.akhmetshin Edgar Akhmetshin
              doctorbal82 Andreas Drbal
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: