Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-17395

Template import with "Delete missing" option doesn't delete application that is configurated linkage template

    XMLWordPrintable

    Details

    • Type: Problem report
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.0.18
    • Component/s: API (A)
    • Labels:
      None
    • Environment:
      Zabbix Server 4.0.18
    • Team:
      Team B
    • Sprint:
      Sprint 62 (Mar 2020), Sprint 63 (Apr 2020)
    • Story Points:
      0.5

      Description

      Steps to reproduce:

      1. Create template "Template A"
      2. Create template "Template B"
      3. Create any item with application "App X" to "Template B"
      4. "Template B" link to "Template A"
      5. Export "Template A" and "Template B"
      6. Update application "App X" to "App Y" in "Template B"
      7. Import the exported XML with "Delete missing" option for "Applications"
        In step7, application "App X" is remained in "Template A" at step7.
      8. Import the exported XML with "Delete missing" option for "Applications" again
        In step8, application "App X" is deleted in "Template A".

       

      I think it is wrong that "App X" is not deleted in step7.

        Attachments

          Activity

            People

            Assignee:
            iivs Ivo Kurzemnieks
            Reporter:
            k.mizutani Kazuhiro Mizutani
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: