Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-17766

Zabbix proxy warns that EnableRemoteCommands parameter is deprecated

    XMLWordPrintable

Details

    • Problem report
    • Status: Closed
    • Trivial
    • Resolution: Duplicate
    • 5.0.0
    • None
    • None
    • None
    • CentOS 7

    Description

      Fresh install of Zabbix proxy 5.0 shows the following in systemctl status:

      zabbix_proxy[18508]: zabbix_proxy [18508]: Warning: EnableRemoteCommands parameter is deprecated, use AllowKey=system.run[*] or DenyKey=system.run[*] instead

      However, config file makes no mention that EnableRemoteCommands is deprecated and using AllowKey=system.run[*] in the config file causes the proxy to fail on startup.

      Attachments

        Issue Links

          Activity

            People

              zabbix.dev Zabbix Development Team
              cszikszoy Chris
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: