Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-18141

Deb packaging: zabbix-sender needs Breaks+Replaces: zabbix-agent

    XMLWordPrintable

    Details

    • Type: Problem report
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 4.0.22
    • Fix Version/s: 5.2 (plan)
    • Component/s: Agent (G)
    • Labels:
      None
    • Team:
      Team I
    • Sprint:
      Sprint 66 (Jul 2020), Sprint 67 (Aug 2020)
    • Story Points:
      1

      Description

       

      Hi,

       

      I'm an experienced debian developer, and my company uses your Debian packages for Zabbix. There's a few concerns that needs to be addressed in your packages.

       

      Upgrading from Zabbix 3.4 to 4.0 fails, because zabbix-sender contains files from zabbix-agent previous version, without declaring something like this:

       

      Package: zabbix-sender
      Breaks: zabbix-agent (<= 1:4.0.22)
      Replaces: zabbix-agent (<= 1:4.0.22)

      Also, I find it a bit silly that the buster version is 1:4.0.22-1+buster and stretch is 1:4.0.22-1+stretch. Indeed, buster is lower than stretch in the alphabetical order. Can I suggest that you switch to:

      1:4.0.22-1+deb9

      1:4.0.22-1+deb10

      so that the version from Stretch is always lower than then one in Buster and allows a correct upgrade?

       

      Cheers,

       

      Thomas Goirand (zigo)

       

        Attachments

          Activity

            People

            Assignee:
            yurii Jurijs Klopovskis
            Reporter:
            zigo Thomas Goirand
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: