Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-18672

Agent .deb packages built without libcURL and LDAP support

    XMLWordPrintable

Details

    • Problem report
    • Status: Closed
    • Trivial
    • Resolution: Fixed
    • 5.2.0, 5.2.1
    • 5.4 (plan)
    • Agent (G)
    • Team I
    • Sprint 70 (Nov 2020), Sprint 71 (Dec 2020)
    • 0.125

    Description

      After upgrade from Zabbix agent 5.0.3 to 5.2.1 (5.2.0 also tested) some items become unsupported:

      Nov 18 15:12:59 ldhost zabbix_agentd[190414]: zabbix_agentd [190414]: Warning: EnableRemoteCommands parameter is deprecated, use AllowKey=system.run[*] or DenyKey=system.run[*] instead
      Nov 18 15:12:59 ldhost zabbix_agentd[190436]: Starting Zabbix Agent [xxx]. Zabbix 5.2.1 (revision 4d0d532fb0).
      Nov 18 15:12:59 ldhost zabbix_agentd[190436]: **** Enabled features ****
      Nov 18 15:12:59 ldhost zabbix_agentd[190436]: IPv6 support:          YES
      Nov 18 15:12:59 ldhost systemd[1]: Started Zabbix Agent.
      Nov 18 15:12:59 ldhost zabbix_agentd[190436]: TLS support:           YES
      Nov 18 15:12:59 ldhost zabbix_agentd[190436]: **************************
      Nov 18 15:12:59 ldhost zabbix_agentd[190436]: using configuration file: /etc/zabbix/zabbix_agentd.conf
      Nov 18 15:12:59 ldhost zabbix_agentd[190436]: agent #0 started [main process]
      Nov 18 15:12:59 ldhost zabbix_agentd[190437]: agent #1 started [collector]
      Nov 18 15:12:59 ldhost zabbix_agentd[190440]: agent #3 started [listener #2]
      Nov 18 15:12:59 ldhost zabbix_agentd[190442]: agent #5 started [active checks #1]
      Nov 18 15:12:59 ldhost zabbix_agentd[190441]: agent #4 started [listener #3]
      Nov 18 15:12:59 ldhost zabbix_agentd[190438]: agent #2 started [listener #1]
      Nov 18 15:13:06 ldhost zabbix_agentd[190442]: active check "net.tcp.service[ldap,srv,]" is not supported: Support for LDAP check was not compiled in.
      Nov 18 15:13:06 ldhost zabbix_agentd[190442]: active check "net.tcp.service[ldap,srv2,389]" is not supported: Support for LDAP check was not compiled in.
      Nov 18 15:13:06 ldhost zabbix_agentd[190442]: active check "web.page.perf[https://www.google.de]" is not supported: Unsupported scheme: https.
      Nov 18 15:13:06 ldhost zabbix_agentd[190442]: active check "web.page.regexp[https://collabora/hosting/capabilities,,,"Collabora Online Development Edition",,]" is not supported: Unsupported scheme: https.
      Nov 18 15:13:06 ldhost zabbix_agentd[190442]: active check "web.page.regexp[https://nextcloud/index.php/login,,,</footer>,,]" is not supported: Unsupported scheme: https.

      net.tcp.service reports a missing compiled LDAP check support and web.page.regexp reports unsupported scheme, which happens if libcURL is not present. There are no problems if downgrading to 5.0.3 using .deb packages from the Zabbix repository.

      Current 5.2 builds seem to use a wrong and different configuration.

      Attachments

        Activity

          People

            yurii Jurijs Klopovskis
            cubic Waldemar Faist
            Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: