Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-18992

Zabbix 5.0 package OpenSSL version changed for RHEL7

    XMLWordPrintable

Details

    • Problem report
    • Status: READY TO DEVELOP
    • Trivial
    • Resolution: Unresolved
    • 5.0.7
    • 5.4 (plan)
    • Packages (C)
    • None
    • Team I
    • Sprint 73 (Feb 2021), Sprint 74 (Mar 2021), Sprint 75 (Apr 2021), Sprint 76 (May 2021), Sprint 77 (Jun 2021), Sprint 78 (Jul 2021), Sprint 79 (Aug 2021), Sprint 80 (Sep 2021), Sprint 81 (Oct 2021)
    • 1

    Description

      Requirements by documents:
      "OpenSSL 1.0.1 or later is required on UNIX platforms"
      but the RPM package depends on OpenSSL 1.0.2 or later.

      https://www.zabbix.com/documentation/5.0/manual/installation/requirements

      It seems that the repo.zabbix.com package dependency has changed since 5.0.2.

      # rpm -qRp zabbix-agent2-5.0.1-1.el7.x86_64.rpm | grep libcrypto 
      警告: zabbix-agent2-5.0.1-1.el7.x86_64.rpm: ヘッダー V4 RSA/SHA512 Signature、鍵 ID a14fe591: NOKEY
      libcrypto.so.10()(64bit)
      libcrypto.so.10(OPENSSL_1.0.1)(64bit)
      libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)
      libcrypto.so.10(libcrypto.so.10)(64bit)
      
      # rpm -qRp zabbix-agent2-5.0.2-1.el7.x86_64.rpm | grep libcrypto 
      警告: zabbix-agent2-5.0.2-1.el7.x86_64.rpm: ヘッダー V4 RSA/SHA512 Signature、鍵 ID a14fe591: NOKEY
      libcrypto.so.10()(64bit)
      libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)
      libcrypto.so.10(OPENSSL_1.0.2)(64bit)
      libcrypto.so.10(libcrypto.so.10)(64bit)
      

      from: https://repo.zabbix.com/zabbix/5.0/rhel/7/x86_64/

      Attachments

        Activity

          People

            yurii Jurijs Klopovskis
            JKKim Kim Jongkwon
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated: