Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-19002

Mattermost integration, test is working, but no real problems send

    XMLWordPrintable

    Details

    • Type: Incident report
    • Status: Closed
    • Priority: Trivial
    • Resolution: Won't fix
    • Affects Version/s: 5.2.4
    • Fix Version/s: None
    • Component/s: Frontend (F)
    • Labels:
      None
    • Environment:
      Arch Linux 5.10.13-arch1-2
      PHP 8.0.2
      MariaDB 10.5.8
      Zabbix: 5.2.4

      Description

      Steps to reproduce:

      1. Setup Zabbix and Mattermost on the same machine
      2. Follow the official documentation to setup the mattermost integration
      3. Try to test the media types (Administration -> Media types -> Mattermost -> Test) and keep  this advice in mind
      4. Go back to the Dashboard or Problems
      5. Wait for a Problem to became real

      Result:

      In the problems overview, I get a "Status" of "failed" for the user "Mattermost user".

      My log says notthing.

      The log was created the following way:

      1. Change `DebugLevel` in `zabbix_server.conf` to `4`
      2. Restart service
      3. `sudo journal -xfn | grep zabbix | grep mattermost

       

      Feb 11 08:53:24 rh-414-pc-43 zabbix_server[142830]: In substitute_key_macros_impl() data:'mysql.dbsize["{$MYSQL.HOST}","{$MYSQL.PORT}","mattermostdb"]'
      Feb 11 08:53:24 rh-414-pc-43 zabbix_server[142830]: End of substitute_key_macros_impl():SUCCEED data:'mysql.dbsize["localhost","3306","mattermostdb"]'
      Feb 11 08:53:24 rh-414-pc-43 zabbix_server[142830]: In get_value() key:'mysql.dbsize["{$MYSQL.HOST}","{$MYSQL.PORT}","mattermostdb"]'
      Feb 11 08:53:24 rh-414-pc-43 zabbix_server[142830]: In get_value_agent() host:'Zabbix server' addr:'127.0.0.1' key:'mysql.dbsize["localhost","3306","mattermostdb"]' conn:'unencrypted'
      Feb 11 08:53:24 rh-414-pc-43 zabbix_server[142830]: Sending [mysql.dbsize["localhost","3306","mattermostdb"]]
      

      Is there another way of addming more logging information?

      My `media types` settings. The tab messages and options wheren't touched.

       

      User settings of tab user.

      User settings of tab media

      User settings of tab permissions

      If I am running a test by using the channel id as the "send_to" value, I get a message inside mattermost.

      So basic stuff like token/authentication is working but I don't know how to debug more.

      I am on this issue since yesterday and all the howtos are doing the same. Especially since the variables I have to provide are such less, it either is a stupid mistake on my side, a little thing missing in the documentation or something else.

      Expected:

      A message is sent via the zabbix bot in mattermost when a problem is detected.

        Attachments

          Activity

            People

            Assignee:
            elina.kuzyutkina Elina Kuzyutkina
            Reporter:
            artodeto Stev Leibelt
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: