Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-19047

Official template "MSSQL by ODBC" - LLD Discovered triggers not updated

    XMLWordPrintable

Details

    • Problem report
    • Status: Closed
    • Trivial
    • Resolution: Cannot Reproduce
    • 5.2.4
    • 5.2.4
    • Server (S), Templates (T)
    • None

    Description

      Steps to reproduce:

      1. Edit any trigger located at: Configuration -> Templates -> MSSQL by ODBC -> Discovery rules -> Database Discovery -> Trigger prototypes
      2. Navigate to a host already holding the template and re-run the discovery rules or wait for 1h (Default: update interval of the template)

      Result:

      1. The template won't update, only re-attach the template will re-create the correct triggers (loosing all history). 

      Expected:

      1. The template gets updated, without the need for re-attach

       

      Image:

      1. This is the host already holding the "old"-trigger (default eval period was 5m)
      2. Shows where that I updated the template (both name & expression) to use {$MSSQL.LOG_FLUSH_WAIT_TIME.EVAL_PERIOD:" {#DBNAME}

        "} as eval period.

        1. I am not sure if the avg expression can hold such a macro, but not relevant as I also had the issue a few days ago when changing the min function (=default template trigger) to avg.

       

      Attachments

        Activity

          People

            rvaliahmetovs Renats Valiahmetovs (Inactive)
            kevinv KevinVerfaille
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: