Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-19053

The feature 'Process tags' for Slack webhook media randomly doesn't work

    XMLWordPrintable

Details

    • Problem report
    • Status: Closed
    • Trivial
    • Resolution: Cannot Reproduce
    • 5.2.5
    • None
    • Server (S)
    • None
    • Team INT

    Description

      Steps to reproduce:

          *    Unfortunately * there is no a guaranteed way to reproduce the problem.
          I noticed that the problem most often occurs when the server generates multiple alerts (4 or more) of the same trigger at the same time. In this case one, or two events will be without tags from slack webhook.

      Result:
      See screenshot...
      Event ID = 949792

      See log file...
      I've added to the Slack webhook line to get debug of tags for each events, to be sure that slack webhook always return always proper tags:

      Zabbix.Log(3, '[ EventID = ' + params.event_id + '] Tags : ' + JSON.stringify(result.tags));

      As result, I see in zabbix server logs information about triggered event from screenshot:

      # grep 949792 /var/log/zabbix/zabbix_server.log
       64205:20210225:025636.882 [ EventID = 949792] Tags : {"__message_ts":"1614218196.043000","__channel_id":"CEZ2QE43U","__channel_name":"emergency","__message_link":"https://kwebbl.slack.com/archives/CEZ2QE43U/p1614218196043000"}

      Slack webhook send correctly tags in all events, but zabbix server don't add tags to the event in some cases.

      Expected:
      See screenshot....

      See attached patch file...

       

      Attachments

        Activity

          People

            zabbix.support Zabbix Support Team
            pavel-z Pavel
            Votes:
            2 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: