Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-19815

XML files exported with 2.0, 2.2 doesn't work for import in Zabbix 5.0

    XMLWordPrintable

Details

    • Team B
    • Sprint 79 (Aug 2021), Sprint 80 (Sep 2021), Sprint 81 (Oct 2021), Sprint 82 (Nov 2021)
    • 5

    Description

      XML Import tag validation in Zabbix 5.0 prevented the import of old XML.

      Zabbix Versions: from => to

      • 2.0.21 => 5.0.14
        Invalid tag "/zabbix_export/templates/template(1)/items/item(1)": the tag "snmpv3_contextname" is missing. [conf.import.php:89 → CApiWrapper->__call() → CFrontendApiWrapper->callMethod() → CApiWrapper->callMethod() → CFrontendApiWrapper->callClientMethod() → CLocalApiClient->callMethod() → CConfiguration->import() → CXmlValidator->validate() → C30XmlValidator->validate() → CXmlValidatorGeneral->doValidate() → CXmlValidatorGeneral->doValidateRecursive() → CXmlValidatorGeneral->doValidateRecursive() → CXmlValidatorGeneral->doValidateRecursive() → CXmlValidatorGeneral->doValidateRecursive() → CXmlValidatorGeneral->doValidateRecursive() in include/classes/import/validators/CXmlValidatorGeneral.php:205]
        
      • 2.2.0 => 5.0.14
        Invalid tag "/zabbix_export/templates/template(1)/items/item(1)": the tag "logtimefmt" is missing. [conf.import.php:89 → CApiWrapper->__call() → CFrontendApiWrapper->callMethod() → CApiWrapper->callMethod() → CFrontendApiWrapper->callClientMethod() → CLocalApiClient->callMethod() → CConfiguration->import() → CXmlValidator->validate() → C30XmlValidator->validate() → CXmlValidatorGeneral->doValidate() → CXmlValidatorGeneral->doValidateRecursive() → CXmlValidatorGeneral->doValidateRecursive() → CXmlValidatorGeneral->doValidateRecursive() → CXmlValidatorGeneral->doValidateRecursive() → CXmlValidatorGeneral->doValidateRecursive() in include/classes/import/validators/CXmlValidatorGeneral.php:205]
        

      (To 3.0.28, 4.0.26 is work )

      Zabbix 5.0 documentation describes the "Version compatibility" of XML import:

      Supported XML files
      XML files, exported with 1.8, 2.0, 2.2, 2.4, 3.0, 3.2, 3.4, 4.0, 4.2 and 4.4 are supported for import in Zabbix 5.0.
      

      Attachments

        Activity

          People

            Miks.Kronkalns Miks Kronkalns
            JKKim Kim Jongkwon
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated: