Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-19886

Incorrect Memory Utilization Reported

    XMLWordPrintable

Details

    • Problem report
    • Status: Closed
    • Trivial
    • Resolution: Cannot Reproduce
    • None
    • None
    • None
    • None
    • Zabbix Server 5.4.3 (PostgreSQL 12.7)
      Zabbix Proxy 5.4.3 (PostgreSQL 13.4)
      Zabbix Agent 2 (5.4.3 Windows x64)
      Windows Server 2008 R2

    Description

      Steps to reproduce:

      1. I am running Zabbix Agent 2 (5.4.3) on a Windows 2008 R2 server
      2. The host is using the Windows memory by Zabbix agent active default template
      3. The host sends data to a Zabbix proxy which is sending data to our Zabbix server (both running 5.4.3)
      4. After the Zabbix agent has been up for a while the memory utilization will start to report an incorrect value that is higher than it should be (see screenshot)
      5. The raw values appear to be correct in the server interface and when I query the agent directly but the calculated value (last(//vm.memory.size[used]) / last(//vm.memory.size[total]) * 100) is wrong on the server (see screenshot)

      Result:

      Expected:
      I am expecting the calculated value to be correct ~75% and not 98.5445%.

      Attachments

        Activity

          People

            zabbix.support Zabbix Support Team
            nslusherota Nathan Slusher
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: