Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-19947

Unable to downgrade packages with apt on Debian-based systems

    XMLWordPrintable

Details

    • Problem report
    • Status: Closed
    • Trivial
    • Resolution: Won't fix
    • 5.4.4
    • None
    • Packages (C)
    • None
    • Team B
    • Sprint 80 (Sep 2021)
    • 1

    Description

      Hello!

      Now we have no ability to downgrade Zabbix packages on Debian-based systems because of repository Package file contains information about latest version only, e.g.:

      apt-cache policy zabbix-agent2 
      zabbix-agent2:
       Installed: 1:5.4.4-1+ubuntu20.04
       Candidate: 1:5.4.4-1+ubuntu20.04
       Version table:
       *** 1:5.4.4-1+ubuntu20.04 500
       500 http://repo.zabbix.com/zabbix/5.4/ubuntu focal/main amd64 Packages
       100 /var/lib/dpkg/status

      So, we cannot do something like this to downgrade to 5.4.3:

      apt install zabbix-agent2=5.4.3
      Reading package lists... Done
      Building dependency tree 
      Reading state information... Done
      E: Version '5.4.3' for 'zabbix-agent2' was not found

      Attachments

        Issue Links

          Activity

            People

              zabbix.support Zabbix Support Team
              asand3r Khatsayuk Alexander
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: