Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-20674

Template import is broken when Debug mode enabled

    XMLWordPrintable

Details

    • Problem report
    • Status: Closed
    • Trivial
    • Resolution: Duplicate
    • 5.4.10
    • None
    • API (A), Frontend (F)
    • None
    • Team C
    • Sprint 85 (Feb 2022)

    Description

      Steps to reproduce:

      1. Enable debug mode for the usergroup where your frontend user included
      2. Try to import the template attached

      Result:

      Import failed, see screenshot and full error description

       

      Incorrect value "'19805'" for unsigned int field "resourceid". [zabbix.php:22 → require_once() → ZBase->run() → ZBase->processRequest() → CController->run() → CControllerPopupImport->doAction() → CApiWrapper->__call() → CFrontendApiWrapper->callMethod() → CApiWrapper->callMethod() → CFrontendApiWrapper->callClientMethod() → CLocalApiClient->callMethod() → CConfiguration->import() → CConfigurationImport->import() → CConfigurationImport->processTriggers() → CTrigger->create() → CTriggerGeneral->createReal() → CApiService->addAuditBulk() → CAudit::addBulk() → DB::insertBatch() → DB::checkValueTypes() → DB::exception() in include/classes/db/DB.php:396]
      

      Attachments

        Issue Links

          Activity

            People

              zabbix.dev Zabbix Development Team
              igorbach Igor Gorbach
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: