Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-20892

Cannot build Zabbix Proxy from sources with static libs

    XMLWordPrintable

Details

    • Incident report
    • Status: Confirmed
    • Minor
    • Resolution: Unresolved
    • 5.0.22
    • None
    • None
    • Ubuntu 20.04.4 with updates

    Description

      Steps to reproduce:

      1. Run ./configure with "--enable-static" option (e.g. I run ./configureĀ  --with-libcurl --with-libevent --with-libpcre --with-libpthread --with-openssl --with-zlib --with-sqlite3 --with-libxml2 --with-gnutls --enable-proxy --enable-static)
      2. Process fails with error "configure: error: Not found libxml2 library"

      I have installed libxml2-dev and all necessary build instruments. If I remove "--enable-static" option configure script end successfully and I can start make process.

      config.log{}

      Attachments

        Activity

          People

            zabbix.dev Zabbix Development Team
            asand3r Khatsayuk Alexander
            Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated: