Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-21500

Raspbian installation with nginx installs also full apache set and makes it default web server

    XMLWordPrintable

Details

    • Problem report
    • Status: Confirmed
    • Major
    • Resolution: Unresolved
    • 6.0.7, 6.2.1
    • None
    • Packages (C)
    • None

    Description

      Steps to reproduce:

      1. Debian11.4 / ARM64
      2. https://www.zabbix.com/download?zabbix=6.2&os_distribution=raspberry_pi_os&os_version=11_bullseye&db=mysql&ws=nginx

      Result:

      #  apt install zabbix-server-mysql zabbix-frontend-php zabbix-nginx-conf zabbix-sql-scripts zabbix-agent
      Reading package lists... Done
      Building dependency tree... Done
      Reading state information... Done
      The following package was automatically installed and is no longer required:
        linux-image-5.10.0-13-arm64
      Use 'sudo apt autoremove' to remove it.
      The following additional packages will be installed:
        apache2 apache2-bin apache2-data apache2-utils fonts-dejavu fonts-dejavu-extra fping geoip-database libapache2-mod-php7.4 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libevent-2.1-7 libgeoip1 libltdl7 liblua5.3-0 libmodbus5
        libnginx-mod-http-geoip libnginx-mod-http-image-filter libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-stream libnginx-mod-stream-geoip libodbc1 libonig5 libopenipmi0 libsensors-config libsensors5 libsnmp-base libsnmp40 libsodium23 libssh-4
        libxslt1.1 nginx nginx-common nginx-core php php-bcmath php-common php-fpm php-gd php-ldap php-mbstring php-mysql php-xml php7.4 php7.4-bcmath php7.4-cli php7.4-common php7.4-fpm php7.4-gd php7.4-json php7.4-ldap php7.4-mbstring php7.4-mysql php7.4-opcache
        php7.4-readline php7.4-xml snmpd ssl-cert
      Suggested packages:
        apache2-doc apache2-suexec-pristine | apache2-suexec-custom www-browser php-pear geoip-bin libmyodbc odbc-postgresql tdsodbc unixodbc-bin lm-sensors snmp-mibs-downloader fcgiwrap nginx-doc snmptrapd zabbix-apache-conf
      The following NEW packages will be installed:
        apache2 apache2-bin apache2-data apache2-utils fonts-dejavu fonts-dejavu-extra fping geoip-database libapache2-mod-php7.4 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libevent-2.1-7 libgeoip1 libltdl7 liblua5.3-0 libmodbus5
        libnginx-mod-http-geoip libnginx-mod-http-image-filter libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-stream libnginx-mod-stream-geoip libodbc1 libonig5 libopenipmi0 libsensors-config libsensors5 libsnmp-base libsnmp40 libsodium23 libssh-4
        libxslt1.1 nginx nginx-common nginx-core php php-bcmath php-common php-fpm php-gd php-ldap php-mbstring php-mysql php-xml php7.4 php7.4-bcmath php7.4-cli php7.4-common php7.4-fpm php7.4-gd php7.4-json php7.4-ldap php7.4-mbstring php7.4-mysql php7.4-opcache
        php7.4-readline php7.4-xml snmpd ssl-cert zabbix-agent zabbix-frontend-php zabbix-nginx-conf zabbix-server-mysql zabbix-sql-scripts
      0 upgraded, 66 newly installed, 0 to remove and 15 not upgraded.
      
      

      Default page returns : Apache Web Server

      Doc says - use 8080 port with nginx

      Expected:
      Do not install apache and do not ask in documentation to use 8080 if apache is even not needed.

      Attachments

        Activity

          People

            zabbix.dev Zabbix Development Team
            edgar.akhmetshin Edgar Akhmetshin
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated: