Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-21612

RPM repository broken on AlmaLinux/RHEL 9

    XMLWordPrintable

Details

    • Problem report
    • Status: Closed
    • Trivial
    • Resolution: Duplicate
    • 6.2.2
    • None
    • Packages (C)
    • None
    • Team B
    • Sprint 92 (Sep 2022)

    Description

      Steps to reproduce:

      1. Add Zabbix rpm repository: rpm -Uvh https://repo.zabbix.com/zabbix/6.2/rhel/9/x86_64/zabbix-release-6.2-2.el9.noarch.rpm
      2. Installl packages: dnf install zabbix-server-mysql zabbix-web-mysql zabbix-apache-conf zabbix-sql-scripts zabbix-selinux-policy zabbix-agent
      3. Run upgrade: dnf upgrade

      Result:
      Upgrade fails:

      [[email protected] ~]# yum upgrade
      AlmaLinux 9 - AppStream                                                                                                                                                                                      3.6 MB/s | 7.9 MB     00:02
      AlmaLinux 9 - BaseOS                                                                                                                                                                                         2.0 MB/s | 3.4 MB     00:01
      AlmaLinux 9 - Extras                                                                                                                                                                                          11 kB/s |  12 kB     00:01
      Extra Packages for Enterprise Linux 9 - x86_64                                                                                                                                                               4.3 MB/s | 9.9 MB     00:02
      Zabbix Official Repository - x86_64                                                                                                                                                                           29 kB/s |  55 kB     00:01
      Zabbix Official Repository non-supported - x86_64                                                                                                                                                            688  B/s | 1.1 kB     00:01
      Zabbix Official Repository (Agent2 Plugins) - x86_64                                                                                                                                                         693  B/s | 1.1 kB     00:01
      Error:
       Problem 1: package zabbix-web-deps-6.2.2-release2.el9.noarch requires zabbix-web = 6.2.2-release2.el9, but none of the providers can be installed
        - cannot install both zabbix-web-1:6.0.5-1.el9.noarch and zabbix-web-6.2.2-release2.el9.noarch
        - cannot install both zabbix-web-6.2.2-release2.el9.noarch and zabbix-web-1:6.0.5-1.el9.noarch
        - cannot install the best update candidate for package zabbix-web-deps-6.2.2-release2.el9.noarch
        - cannot install the best update candidate for package zabbix-web-6.2.2-release2.el9.noarch
       Problem 2: package zabbix-apache-conf-6.2.2-release2.el9.noarch requires zabbix-web-deps = 6.2.2-release2.el9, but none of the providers can be installed
        - package zabbix-web-deps-6.2.2-release2.el9.noarch requires zabbix-web = 6.2.2-release2.el9, but none of the providers can be installed
        - cannot install both zabbix-web-1:6.0.5-1.el9.noarch and zabbix-web-6.2.2-release2.el9.noarch
        - cannot install both zabbix-web-6.2.2-release2.el9.noarch and zabbix-web-1:6.0.5-1.el9.noarch
        - package zabbix-web-mysql-1:6.0.5-1.el9.noarch requires zabbix-web = 1:6.0.5-1.el9, but none of the providers can be installed
        - cannot install the best update candidate for package zabbix-web-mysql-6.2.2-release2.el9.noarch
        - cannot install the best update candidate for package zabbix-apache-conf-6.2.2-release2.el9.noarch
      (try to add '-allowerasing' to command line to replace conflicting packages or '-nobest' to use not only best candidate packages)
      [[email protected] ~]#

      Already installed packages:

      [[email protected] ~]# rpm -qa|grep -i zabbix
      zabbix-release-6.2-2.el9.noarch
      zabbix-web-6.2.2-release2.el9.noarch
      zabbix-web-mysql-6.2.2-release2.el9.noarch
      zabbix-web-deps-6.2.2-release2.el9.noarch
      zabbix-apache-conf-6.2.2-release2.el9.noarch
      zabbix-agent-6.2.2-release1.el9.x86_64
      zabbix-server-mysql-6.2.2-release1.el9.x86_64
      zabbix-sql-scripts-6.2.2-release1.el9.noarch
      zabbix-selinux-policy-6.2.2-release1.el9.x86_64
      zabbix-sender-6.2.2-release1.el9.x86_64
      [[email protected] ~]#

      Expected:
      Upgrade command works as normal

      Attachments

        Issue Links

          Activity

            People

              yurii Jurijs Klopovskis
              redshift Glenn Matthys
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: