Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-21727

zabbix-server OL8 docker image uses old unsupported postgres v10 libraries

    XMLWordPrintable

Details

    Description

      Zabbix-Server OL8 docker image (as recent as 6.2.3) is using old, obseleted postgres v10 libraries e.g. postgresql;10.21-2.module+el8.6.0+20673+e7bc7ac8;x86_64;installed

       

      These contain a number of HIGH vulnerabilities. 

       

      Recommend these are moved to a newer version of postgres e.g. 13. This is how I am doing it in my own docker image:

      cd /tmp/
      curl https://download.postgresql.org/pub/repos/yum/reporpms/EL-7-x86_64/pgdg-redhat-repo-latest.noarch.rpm -o postgres.rpm
      rpm -i postgres.rpmmicrodnf remove postgresql
      microdnf module reset postgresql
      microdnf module enable postgresql:13
      microdnf install postgresql
      microdnf update

      Attachments

        Activity

          People

            zabbix.support Zabbix Support Team
            steve.falzon@securityshift.com Steve
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: