Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-21728

Zabbix-agent binary for Linux 3.0 kernel not working on the latest systems

    XMLWordPrintable

Details

    • Incident report
    • Resolution: Won't fix
    • Trivial
    • None
    • 6.0.9
    • Agent (G), Packages (C)
    • None
    • Team B
    • Support backlog, Sprint 93 (Oct 2022), Sprint 94 (Nov 2022), Sprint 95 (Dec 2022), Sprint 96 (Jan 2023), Sprint 97 (Feb 2023), Sprint 98 (Mar 2023), Sprint 99 (Apr 2023), Sprint 100 (May 2023), Sprint 101 (Jun 2023), Sprint 102 (Jul 2023), Sprint 103 (Aug 2023), Sprint 104 (Sep 2023)

    Description

      Steps to reproduce:

      1. Download the agentĀ 

      https://cdn.zabbix.com/zabbix/binaries/stable/6.0/6.0.9/zabbix_agent-6.0.9-linux-3.0-amd64-static.tar.gz

      2. Unzip the archive

      3. Run the agent

      /path/to/zabbix_agentd -c /path/to/zabbix_agentd.conf

      Result:
      Segmentation fault error without any useful information


      Expected:
      No errors for static-based binary, because this one is the only one available for download.

      Agents for Linux 4.x/5.x kernel and amd64 architectures are unavailable

      Attachments

        Activity

          People

            jlambda Juris Lambda
            igorbach Igor Gorbach
            Votes:
            3 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: