Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-21835

FTBFS in "golang.org/x/sys": "unsafe.Slice requires go1.17 or later"

    XMLWordPrintable

Details

    • Problem report
    • Status: Need info
    • Trivial
    • Resolution: Unresolved
    • 6.0.9
    • None
    • Agent2 plugin (N)
    • Debian "unstable"

    Description

      As reported in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1023046
      Zabbix FTBFS in Debian "unstable" as follows:

       

      > # golang.org/x/sys/unix
      > vendor/golang.org/x/sys/unix/syscall.go:83:16: unsafe.Slice requires go1.17 or later (-lang was set to go1.16; check go.mod)
      > vendor/golang.org/x/sys/unix/syscall_linux.go:2255:9: unsafe.Slice requires go1.17 or later (-lang was set to go1.16; check go.mod)
      > vendor/golang.org/x/sys/unix/syscall_unix.go:118:7: unsafe.Slice requires go1.17 or later (-lang was set to go1.16; check go.mod)
      > vendor/golang.org/x/sys/unix/sysvshm_unix.go:33:7: unsafe.Slice requires go1.17 or later (-lang was set to go1.16; check go.mod)
      > zabbix.com/pkg/procfs
      > # golang.org/x/sys/unix
      > vendor/golang.org/x/sys/unix/syscall.go:83:16: unsafe.Slice requires go1.17 or later (-lang was set to go1.16; check go.mod)
      > vendor/golang.org/x/sys/unix/syscall_linux.go:2255:9: unsafe.Slice requires go1.17 or later (-lang was set to go1.16; check go.mod)
      > vendor/golang.org/x/sys/unix/syscall_unix.go:118:7: unsafe.Slice requires go1.17 or later (-lang was set to go1.16; check go.mod)
      > vendor/golang.org/x/sys/unix/sysvshm_unix.go:33:7: unsafe.Slice requires go1.17 or later (-lang was set to go1.16; check go.mod)

      Attachments

        Activity

          People

            igorbach Igor Gorbach
            onlyjob Dmitry Smirnov
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated: