Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-21865

Zabbix 6.0 LTS install from repo fails with dependency resolution failure

    XMLWordPrintable

Details

    • Problem report
    • Status: Closed
    • Trivial
    • Resolution: Duplicate
    • 6.0.10
    • None
    • Packages (C)
    • New Rocky9 minimal install after running yum update.
    • 0

    Description

      Steps to reproduce:

      1. Create new Rocky9 VM, run yum update
      2. Install mariadb-server
      3. Follow official installation instructions at https://www.zabbix.com/download for Zabbix 6.0LTS / Rocky 9 / Server, Frontend, Agent / Mysql / Apache
      4.  

      Result:

      This command:

      {{{{dnf install zabbix-server-mysql zabbix-web-mysql zabbix-apache-conf zabbix-sql-scripts zabbix-selinux-policy zabbix-agent }}}}

      fails to fulfil dependencies and gives this error:

      Error: 
       Problem: package zabbix-web-deps-6.0.10-release1.el9.noarch requires zabbix-web = 6.0.10-release1.el9, but none of the providers can be installed
        - cannot install both zabbix-web-6.0.10-release1.el9.noarch and zabbix-web-1:6.0.8-1.el9.noarch
        - package zabbix-apache-conf-6.0.10-release1.el9.noarch requires zabbix-web-deps = 6.0.10-release1.el9, but none of the providers can be installed
        - package zabbix-web-mysql-1:6.0.8-1.el9.noarch requires zabbix-web = 1:6.0.8-1.el9, but none of the providers can be installed
        - cannot install the best candidate for the job
      (try to add '-allowerasing' to command line to replace conflicting packages or 'skip-broken' to skip uninstallable packages or '-nobest' to use not only best candidate packages)

      Running the command again with option --nobest allows package installation to complete with these out-of-sync versions:

      [[email protected] ~]# rpm -qa zabbix-web
      zabbix-web-6.0.10-release1.el9.noarch
      [[email protected] ~]# rpm -qa zabbix-web-mysql
      zabbix-web-mysql-6.0.10-release1.el9.noarch

      I cannot determine yet if these different versions of packages work correctly together

       

      Expected:

      All Zabbix components should successfully resolve with their dependencies, either version 6.0.8 or 6.0.10, which ever is newest

      Attachments

        Issue Links

          Activity

            People

              avolodin Aleksey Volodin
              alan.mckinnon@mtn.com Alan McKinnon
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: