Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-2228

Recently zabbix-server do not want to compile on FreeBSD 8.0-RELEASE (Not found LBER library)

    Details

    • Type: Incident report
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.2, 1.9.0 (alpha)
    • Fix Version/s: 1.8.2, 1.9.0 (alpha)
    • Component/s: None
    • Labels:
      None
    • Environment:
      FreeBSD 8.0-RELEASE

      Description

      Zabbix-server do not want to compile on FreeBSD 8.0-RELEASE if it compiled with LDAP
      Some time ago it was compiled well (1-2 weeks in the past).
      I think after the merging ZBX-2006 this error started to occur.

      my command:
      ./configure --enable-server --with-mysql --with-net-snmp --with-jabber --with-libcurl --enable-ipv6 --with-ldap

      end of result my configure command:
      checking for localname in struct snmp_session... yes
      test: x: unexpected operator
      checking for LDAP support... yes
      checking for main in -llber... no
      configure: error: Not found LBER library

      config.log attached

      Sorry if I'm wrong.

        Attachments

          Activity

            People

            • Assignee:
              sasha Alexander Vladishev
              Reporter:
              zalex_ua Oleksiy Zagorskyi
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: