Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-2301

Can't configure zabbix with libssh2 1.0.0 library

    Details

    • Type: Incident report
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.2
    • Fix Version/s: 1.8.3
    • Component/s: Proxy (P), Server (S)
    • Labels:
      None
    • Environment:
      libssh2-1.0.0

      Description

      ./configure --enable-server --with-mysql --prefix=`pwd` --with-ssh2=/home/sasha/dists/libssh2-1.0-install
      checking for a BSD-compatible install... /usr/bin/install -c
      checking whether build environment is sane... yes
      checking for gawk... no
      checking for mawk... mawk
      checking whether make sets $(MAKE)... yes
      .....
      checking for main in -lcurl... yes
      checking whether libcurl is usable... yes
      checking for curl_free... yes
      checking for SSH2 support... ./configure: line 12212: test: -ge: unary operator expected
      yes
      configure: error: SSH2 library version requirement not met (>= 1.0.0)

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              sasha Alexander Vladishev
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: