Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-23301

Incompatible TimescaleDB version listed as supported in documentation

    XMLWordPrintable

Details

    • Team I
    • Sprint 103 (Aug 2023), Sprint 104 (Sep 2023), Sprint 105 (Oct 2023), Sprint 106 (Nov 2023), Sprint 107 (Dec 2023), Sprint candidates, S2401
    • 1

    Description

      In documentation article Requirements versions 2.0.1 to 2.11 for TimescaleDB are listed as supported. Version 2.0.1 of TimescaleDB does not support PostgreSQL 13.0, which is another requirement for Zabbix. More info on supported PSQL versions here.

      Additionally, when trying to build Timescale 2.0.1 on a machine with PostgreSQL 13 you get this error:

      -- Compiling against PostgreSQL version 13.12
      CMake Error at CMakeLists.txt:244 (message):
        TimescaleDB only supports PostgreSQL 11 and 12
      
      
      -- Configuring incomplete, errors occurred!
      

      Support for PostgreSQL 13 was added on TimescaleDB version 2.1.0 - release notes here. The oldest supported TimescaleDB version should be changed to 2.1.0.

      Note: this also means changes in Server and Frontend checks. Server checks DB version when starting. Frontend shows a warning in Administration -> Housekeeping when the version is not supported.

      Attachments

        Issue Links

          Activity

            People

              dimir dimir
              jnulle Janis Nulle
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated: