ZABBIX BUGS AND ISSUES
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-2341

Shortening the text value displayed is not very correctly if it is non-english text (russian for example).

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.2
    • Fix Version/s: 1.8.4
    • Component/s: Frontend (F)
    • Labels:
      None

      Description

      In the file 'include\items.inc.php' function 'format_lastvalue' should be improved to correctly display the last letter and and number ot letters in the case of non-English text.
      On screenshot square symbol (in the red circle) is first byte of two-bytes UTF8 letter. Is the byte №20

      Simple selection of the first 20 bytes are not the best choice. Must choose 20 letters.

        Activity

        Alexei Vladishev added a comment -

        Other screens might be affected as well.

        Alexey Fukalov added a comment -

        branches/1.8 11845

        Oleksiy Zagorskyi added a comment -

        Tested. Now displayed correctly.

        Oleksiy Zagorskyi added a comment -

        Under http://www.zabbix.com/documentation/1.8/manual/about/what_s_new_1.8.2#frontend_requirement_changes
        "Parameter mbstring.func_overload not required anymore."
        I recently turned off 'mbstring.func_overload 2' in php.ini, and noticed that the problem came back as I pointed out in the first post.

        FreeBSD 8.0-RELEASE
        apache-2.2.15_4
        php5-5.3.2
        php5-mbstring-5.3.2

        Alexey Fukalov added a comment -

        branches/1.8 12332

        Oleksiy Zagorskyi added a comment -

        Alexei, i see "triggers.inc.php" was changed, but the problem as I wrote on the OVERVIEW page.
        See my first screen shot.

        Alexey Fukalov added a comment -

        Did you just comment mbstring.func_overload 2 string in php.ini and after that frontend strings got broken?

        I cannot reproduce this, it should work without overload enabled..

        Oleksiy Zagorskyi added a comment -

        Yes, one week ago i just comment 'mbstring.func_overload 2' string in php.ini (and restart Apache certainly) i and after that frontend strings got broken.
        Problem with only non-english Text (russian for example) - exactly as on first screen shot.
        If i UNcomment 'mbstring...2' and restart Apache then strings not broken.
        I check this on two different web-server with same result. How i may check more detail?

        Oleksiy Zagorskyi added a comment - - edited

        Full string from history with "square" symbol at end of shortening text:
        Время работоспособного состояния 490543 секунд.

        Not all lines are displayed with the "square" symbol at the end - it depends on the count of single-byte symbol as space or points, or others. If the pair count of them - then the "square" NOT visible, and if unpair count - then VISIBLE.
        But the number of Cyrillic letters is always less than 20 - about 10 or slightly more depending on the availability of single-byte characters inside As I have said above.

        item type very simply: eventlog[System]

        Oleksiy Zagorskyi added a comment -

        Additional testing on a completely different installation (different server, client, etc.). mbstring.func_overload DISABLED
        This was a new Zabbix-server installation 4 days ago from trunk revision 12343.
        Frontend under which I now tested - last trunk revision 12498.
        The negative result is the same which I wrote above. What else can I help?

        Environment:
        Linux 2.6.18-194.3.1.el5 #1 SMP Thu May 13 13:09:10 EDT 2010 i686 i686 i386 GNU/Linux
        Zabbix Server v1.9 (revision 12343) (7 December 2009) Compilation time: May 28 2010 22:19:29
        Zabbix Agent Win32 (service) v1.8.2 (revision 11189) (29 March 2010) Compilation time: Mar 29 2010 17:26:06
        client OS - WinXP SP3 RUS
        php-5.3.2-1.el5.remi
        php-snmp-5.3.2-1.el5.remi
        php-gd-5.3.2-1.el5.remi
        php-mysql-5.3.2-1.el5.remi
        php-mbstring-5.3.2-1.el5.remi
        php-pdo-5.3.2-1.el5.remi
        php-bcmath-5.3.2-1.el5.remi
        mysql-devel-5.1.47-1.el5.remi
        mysql-5.1.47-1.el5.remi
        mysql-server-5.1.47-1.el5.remi
        httpd-2.2.3-43.el5.centos

        Alexey Fukalov added a comment -

        branches/1.8 12525
        should be fixed there

        Oleksiy Zagorskyi added a comment -

        ha-ha. Once again I was right, it's nice
        Tested on two different servers - now displayed correctly.

        Alexey Fukalov added a comment -

        Then i close this easy to fix, but haard to find bug


          People

          • Assignee:
            Alexey Fukalov
            Reporter:
            Oleksiy Zagorskyi
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: