Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-24093

CVE-2024-22121 fix causes unsupported JNDI service provider error

XMLWordPrintable

    • Team A
    • S24-W8/9, S24-W10/11, S24-W12/13
    • 1

      Steps to reproduce:

      1. install latest Zabbix Java Gateway
      2. monitor some Java (JBOSS) app with 'remote+http' protocol

      Result:

      2024-02-07 10:17:37.685 \[pool-1-thread-1] WARN com.zabbix.gateway.SocketProcessor - error processing request: com.zabbix.gateway.ZabbixException: unsupported JNDI service provider, "": service:jmx:remote+[http://x.x.x.x:yyyy|http://x.x.x.x:yyyy]

      Expected:
      CVE-2024-22121 fix should not remove functionality to make something secure. 

            dimir dimir
            edgar.akhmetshin Edgar Akhmetshin
            Team A
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Created:
              Updated:
              Resolved: